summaryrefslogtreecommitdiff
path: root/sys-devel/distcc/distcc-3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /sys-devel/distcc/distcc-3.3.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'sys-devel/distcc/distcc-3.3.ebuild')
-rw-r--r--sys-devel/distcc/distcc-3.3.ebuild52
1 files changed, 27 insertions, 25 deletions
diff --git a/sys-devel/distcc/distcc-3.3.ebuild b/sys-devel/distcc/distcc-3.3.ebuild
index fb9e944df2b1..4ee28df450ff 100644
--- a/sys-devel/distcc/distcc-3.3.ebuild
+++ b/sys-devel/distcc/distcc-3.3.ebuild
@@ -12,7 +12,7 @@ DESCRIPTION="Distribute compilation of C code across several machines on a netwo
HOMEPAGE="http://distcc.org/"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="gnome gssapi gtk hardened ipv6 selinux xinetd zeroconf"
@@ -48,9 +48,6 @@ S="${WORKDIR}/${MY_P}"
pkg_setup() {
enewuser distcc 240 -1 -1 daemon
python-single-r1_pkg_setup
-
- DCCC_PATH="/usr/$(get_libdir)/distcc/bin"
- DISTCC_VERBOSE="0"
}
src_prepare() {
@@ -65,34 +62,36 @@ src_prepare() {
use hardened && eapply "${FILESDIR}/distcc-hardened.patch"
sed -i \
- -e "/PATH/s:\$distcc_location:${EPREFIX}${DCCC_PATH}:" \
+ -e "/PATH/s:\$distcc_location:${EPREFIX}/usr/lib/distcc/bin:" \
-e "s:@PYTHON@:${EPYTHON}:" \
pump.in || die "sed failed"
sed \
-e "s:@EPREFIX@:${EPREFIX:-/}:" \
- -e "s:@libdir@:/usr/$(get_libdir):" \
+ -e "s:@libdir@:/usr/lib:" \
"${FILESDIR}/3.2/distcc-config" > "${T}/distcc-config" || die
hprefixify update-distcc-symlinks.py src/{serve,daemon}.c
}
src_configure() {
- local myconf="--disable-Werror"
+ local myconf=(
+ --disable-Werror
+ $(use_with gtk)
+ $(use_with gnome)
+ $(use_with gssapi auth)
+ $(use_with zeroconf avahi)
+ )
# --disable-rfc2553 b0rked, bug #254176
- use ipv6 && myconf="${myconf} --enable-rfc2553"
-
- econf \
- $(use_with gtk) \
- $(use_with gnome) \
- $(use_with gssapi auth) \
- $(use_with zeroconf avahi) \
- ${myconf}
+ use ipv6 && myconf+=(--enable-rfc2553)
+
+ econf "${myconf[@]}"
}
src_install() {
- default
+ # override GZIP_BIN to stop it from compressing manpages
+ emake DESTDIR="${D}" GZIP_BIN=false install
python_optimize
newinitd "${FILESDIR}/3.2/init" distccd
@@ -111,7 +110,7 @@ src_install() {
fi
doconfd "${T}/distccd"
- cat > "${T}/02distcc" <<-EOF || die
+ newenvd - 02distcc <<-EOF || die
# This file is managed by distcc-config; use it to change these settings.
# DISTCC_LOG and DISTCC_DIR should not be set.
DISTCC_VERBOSE="${DISTCC_VERBOSE:-0}"
@@ -123,9 +122,8 @@ src_install() {
DISTCC_ENABLE_DISCREPANCY_EMAIL="${DISTCC_ENABLE_DISCREPANCY_EMAIL}"
DCC_EMAILLOG_WHOM_TO_BLAME="${DCC_EMAILLOG_WHOM_TO_BLAME}"
EOF
- doenvd "${T}/02distcc"
- keepdir "${DCCC_PATH%bin}"
+ keepdir /usr/lib/distcc
dobin "${T}/distcc-config"
@@ -142,8 +140,8 @@ src_install() {
fi
insinto /usr/share/shadowman/tools
- newins - distcc <<<"${EPREFIX}${DCCC_PATH}"
- newins - distccd <<<"${EPREFIX}${DCCC_PATH%bin}"
+ newins - distcc <<<"${EPREFIX}/usr/lib/distcc/bin"
+ newins - distccd <<<"${EPREFIX}/usr/lib/distcc"
rm -r "${ED}/etc/default" || die
rm "${ED}/etc/distcc/clients.allow" || die
@@ -151,6 +149,12 @@ src_install() {
}
pkg_postinst() {
+ # remove the old paths when switching from libXX to lib
+ if [[ $(get_libdir) != lib && ${SYMLINK_LIB} != yes && \
+ -d ${EROOT%/}/usr/$(get_libdir)/distcc ]]; then
+ rm -r -f "${EROOT%/}/usr/$(get_libdir)/distcc" || die
+ fi
+
if [[ ${ROOT} == / ]]; then
eselect compiler-shadow update distcc
eselect compiler-shadow update distccd
@@ -162,10 +166,8 @@ pkg_postinst() {
elog "Tips on using distcc with Gentoo can be found at"
elog "https://wiki.gentoo.org/wiki/Distcc"
elog
- elog "How to use pump mode with Gentoo:"
- elog "# distcc-config --set-hosts \"foo,cpp,lzo bar,cpp,lzo baz,cpp,lzo\""
- elog "# echo 'FEATURES=\"\${FEATURES} distcc distcc-pump\"' >> /etc/portage/make.conf"
- elog "# emerge -u world"
+ elog "distcc-pump is known to cause breakage with multiple packages."
+ elog "Do NOT enable it globally."
elog
elog "To use the distccmon programs with Gentoo you should use this command:"
elog "# DISTCC_DIR=\"${DISTCC_DIR:-${BUILD_PREFIX}/.distcc}\" distccmon-text 5"