summaryrefslogtreecommitdiff
path: root/sys-devel/crossdev/crossdev-20230923.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-23 17:20:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-23 17:20:27 +0100
commitb42afc2e976bde12586d398e7cb53b7910866059 (patch)
treef386626e5aca8450407cab0ab30bda6098b87134 /sys-devel/crossdev/crossdev-20230923.ebuild
parent2b180aa1d688b249ea9ce233bc8789031b2020aa (diff)
gentoo auto-resync : 23:09:2023 - 17:20:26
Diffstat (limited to 'sys-devel/crossdev/crossdev-20230923.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-20230923.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-devel/crossdev/crossdev-20230923.ebuild b/sys-devel/crossdev/crossdev-20230923.ebuild
new file mode 100644
index 000000000000..8938d96f9d54
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20230923.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/crossdev.git
+ https://github.com/gentoo/crossdev
+ "
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ app-shells/bash
+ sys-apps/gentoo-functions
+ sys-apps/config-site
+"
+BDEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ ${PV} == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+
+ dodir /usr/share/config.site.d
+ mv "${ED}"/usr/share/config.site{,.d/80crossdev.conf} || die
+}