summaryrefslogtreecommitdiff
path: root/sys-devel/cproc/cproc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-25 08:49:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-25 08:49:31 +0100
commitfae5c40540ab2ebf93e2291bfec510022df02bdc (patch)
tree880ed6d0aeb733ec8f65369d877df65141eaa942 /sys-devel/cproc/cproc-9999.ebuild
parentca125edb1c8e51bd222fec61eb155151bbd4b791 (diff)
gentoo auto-resync : 25:08:2022 - 08:49:31
Diffstat (limited to 'sys-devel/cproc/cproc-9999.ebuild')
-rw-r--r--sys-devel/cproc/cproc-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/cproc/cproc-9999.ebuild b/sys-devel/cproc/cproc-9999.ebuild
new file mode 100644
index 000000000000..163ffe80afba
--- /dev/null
+++ b/sys-devel/cproc/cproc-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://git.sr.ht/~mcf/cproc"
+ inherit git-r3
+else
+ CPROC_COMMIT="6fabc79d81de56b6c1cdcc2242933fd792e2ddf9"
+ CPROC_P="${PN}-${CPROC_COMMIT}"
+ SRC_URI="https://git.sr.ht/~mcf/cproc/archive/${CPROC_COMMIT}.tar.gz -> ${CPROC_P}.tar.gz"
+ S="${WORKDIR}/${CPROC_P}"
+
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+DESCRIPTION="C11 compiler using QBE as backend"
+HOMEPAGE="https://sr.ht/~mcf/cproc/"
+
+LICENSE="ISC"
+SLOT="0"
+
+DEPEND="sys-devel/qbe"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ rm -r "${S}/qbe" || die
+}
+
+src_configure() {
+ tc-export CC
+
+ edo ./configure --prefix=/usr
+}