summaryrefslogtreecommitdiff
path: root/sys-devel/clang/clang-18.1.0_rc2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-18 17:39:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-18 17:39:04 +0000
commit9897403e8218123dc1c8d3797b083652f08779a9 (patch)
tree4094b584adf5bb6134895d92d675388b79bc13a0 /sys-devel/clang/clang-18.1.0_rc2.ebuild
parent08f1ae6b8bd1202a10c5f0d07ee0adc846e0308c (diff)
gentoo auto-resync : 18:02:2024 - 17:39:04
Diffstat (limited to 'sys-devel/clang/clang-18.1.0_rc2.ebuild')
-rw-r--r--sys-devel/clang/clang-18.1.0_rc2.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sys-devel/clang/clang-18.1.0_rc2.ebuild b/sys-devel/clang/clang-18.1.0_rc2.ebuild
index d351f9774a48..189ad24d33b1 100644
--- a/sys-devel/clang/clang-18.1.0_rc2.ebuild
+++ b/sys-devel/clang/clang-18.1.0_rc2.ebuild
@@ -33,10 +33,6 @@ RDEPEND="
"
BDEPEND="
${PYTHON_DEPS}
- doc? ( $(python_gen_cond_dep '
- dev-python/myst-parser[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- ') )
xml? ( virtual/pkgconfig )
"
PDEPEND="
@@ -55,6 +51,15 @@ LLVM_TEST_COMPONENTS=(
LLVM_USE_TARGETS=llvm
llvm.org_set_globals
+[[ -n ${LLVM_MANPAGE_DIST} ]] && BDEPEND+=" doc? ( "
+BDEPEND+="
+ $(python_gen_cond_dep '
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+"
+[[ -n ${LLVM_MANPAGE_DIST} ]] && BDEPEND+=" ) "
+
# Multilib notes:
# 1. ABI_* flags control ABIs libclang* is built for only.
# 2. clang is always capable of compiling code for all ABIs for enabled