summaryrefslogtreecommitdiff
path: root/sys-devel/clang/clang-15.0.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-11 23:39:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-11 23:39:55 +0100
commit7d040c2d1b0c38c8635ec28dfaa632a2db8be895 (patch)
tree78e9474cad949bcd1254749d61f4f6b9e7d488bf /sys-devel/clang/clang-15.0.7-r1.ebuild
parent0d39cf7bd8aae36b5d8eb4272a42dc6919216e34 (diff)
gentoo auto-resync : 11:04:2023 - 23:39:54
Diffstat (limited to 'sys-devel/clang/clang-15.0.7-r1.ebuild')
-rw-r--r--sys-devel/clang/clang-15.0.7-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-15.0.7-r1.ebuild b/sys-devel/clang/clang-15.0.7-r1.ebuild
index 3a9fc612178a..7141f0e0a887 100644
--- a/sys-devel/clang/clang-15.0.7-r1.ebuild
+++ b/sys-devel/clang/clang-15.0.7-r1.ebuild
@@ -431,6 +431,13 @@ src_install() {
multilib_src_install() {
DESTDIR=${D} cmake_build install-distribution
+ if multilib_is_native_abi; then
+ # install clang-*-wrapper tools
+ # https://bugs.gentoo.org/904143
+ exeinto "/usr/lib/llvm/${LLVM_MAJOR}/bin"
+ doexe "${BUILD_DIR}"/bin/clang-{linker,nvlink}-wrapper
+ fi
+
# move headers to /usr/include for wrapping & ABI mismatch checks
# (also drop the version suffix from runtime headers)
rm -rf "${ED}"/usr/include || die