summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-06 22:26:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-06 22:26:54 +0100
commitb50dd652d8e73a93ecd53b7520f2e841a05911f0 (patch)
tree4bc388dbb23631151ca68bacfd264f9ccbf89006 /sys-devel/clang-runtime
parent3221bf225fb68a31e281fcdbfde4cea0d576d946 (diff)
gentoo auto-resync : 06:09:2023 - 22:26:53
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/Manifest1
-rw-r--r--sys-devel/clang-runtime/clang-runtime-18.0.0_pre20230906.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/Manifest b/sys-devel/clang-runtime/Manifest
index f483fb03292e..77ba4f6f7d2a 100644
--- a/sys-devel/clang-runtime/Manifest
+++ b/sys-devel/clang-runtime/Manifest
@@ -7,4 +7,5 @@ EBUILD clang-runtime-17.0.0_rc4.ebuild 1351 BLAKE2B 2d30237a865c2abd5b7d2ae2c641
EBUILD clang-runtime-18.0.0.9999.ebuild 1351 BLAKE2B 2d30237a865c2abd5b7d2ae2c64167c82103d7abd4ff09b47f26348cac5aed3fe78da821b9d6f12cebdef2abb8c85f5a48834cba65e60091d787886bebaa29fb SHA512 5197003db8e6ed5292d5e07f171922600c9eed2a6c36c5b498b08a850e74376d88730a4c460c9b5456e9379460779ecc345ec824e513651b0985eb6fd6b6e8d1
EBUILD clang-runtime-18.0.0_pre20230825.ebuild 1351 BLAKE2B 2d30237a865c2abd5b7d2ae2c64167c82103d7abd4ff09b47f26348cac5aed3fe78da821b9d6f12cebdef2abb8c85f5a48834cba65e60091d787886bebaa29fb SHA512 5197003db8e6ed5292d5e07f171922600c9eed2a6c36c5b498b08a850e74376d88730a4c460c9b5456e9379460779ecc345ec824e513651b0985eb6fd6b6e8d1
EBUILD clang-runtime-18.0.0_pre20230829.ebuild 1351 BLAKE2B 2d30237a865c2abd5b7d2ae2c64167c82103d7abd4ff09b47f26348cac5aed3fe78da821b9d6f12cebdef2abb8c85f5a48834cba65e60091d787886bebaa29fb SHA512 5197003db8e6ed5292d5e07f171922600c9eed2a6c36c5b498b08a850e74376d88730a4c460c9b5456e9379460779ecc345ec824e513651b0985eb6fd6b6e8d1
+EBUILD clang-runtime-18.0.0_pre20230906.ebuild 1351 BLAKE2B 2d30237a865c2abd5b7d2ae2c64167c82103d7abd4ff09b47f26348cac5aed3fe78da821b9d6f12cebdef2abb8c85f5a48834cba65e60091d787886bebaa29fb SHA512 5197003db8e6ed5292d5e07f171922600c9eed2a6c36c5b498b08a850e74376d88730a4c460c9b5456e9379460779ecc345ec824e513651b0985eb6fd6b6e8d1
MISC metadata.xml 661 BLAKE2B 24688c511713ea102b83c71d226d519981b3aee0e05ef7a56d6a80be829efd843194e45cb4fd801f0bb976b6f1976386d6a2b05d2bc907fe2aa42b22b85b7d1f SHA512 2b5ab8783c90795f2e7d1673d876048ed9745f4911fb7a860df56deac13a6dfeba4581a84562eae54eff757c45042ca3fab75c7800313ae61df9ce69780a9294
diff --git a/sys-devel/clang-runtime/clang-runtime-18.0.0_pre20230906.ebuild b/sys-devel/clang-runtime/clang-runtime-18.0.0_pre20230906.ebuild
new file mode 100644
index 000000000000..c69faa0fbdd7
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-18.0.0_pre20230906.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="${PV%%.*}"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-16,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}