summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
commit318828e81fe6707ce5a64e6a59a76d4c0ca709f8 (patch)
treecc4b7818f7960cb193ad2bf7f7defe71adb3ee47 /sys-devel/clang-runtime
parent590c04803f88a968b4a750c0f420eb314e1fe968 (diff)
gentoo auto-resync : 19:09:2023 - 23:10:29
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/Manifest1
-rw-r--r--sys-devel/clang-runtime/clang-runtime-17.0.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/Manifest b/sys-devel/clang-runtime/Manifest
index 568aab9386c2..b45cb1e355ed 100644
--- a/sys-devel/clang-runtime/Manifest
+++ b/sys-devel/clang-runtime/Manifest
@@ -3,6 +3,7 @@ EBUILD clang-runtime-15.0.7.ebuild 759 BLAKE2B d7b481faffc4da0a6dc1b4e708322cd17
EBUILD clang-runtime-16.0.6.ebuild 1435 BLAKE2B dfbb6047c0541de72f3447fa61f00d96c2b7c4b96454fa82796f59bd2884ecdbb01539bf08741d3b5ed866b18f4003bca6878cac549b6ef46aa5c6a15bc56c85 SHA512 d63983cb60299866a743ff6b71279b433a10f011fc51e53f3d3d6d6b99dffc080ef0110e21b4dd6b8a54bceb47035d28bf670e6e81fd0939630b593912d77eb5
EBUILD clang-runtime-17.0.0_rc4.ebuild 1351 BLAKE2B 2d30237a865c2abd5b7d2ae2c64167c82103d7abd4ff09b47f26348cac5aed3fe78da821b9d6f12cebdef2abb8c85f5a48834cba65e60091d787886bebaa29fb SHA512 5197003db8e6ed5292d5e07f171922600c9eed2a6c36c5b498b08a850e74376d88730a4c460c9b5456e9379460779ecc345ec824e513651b0985eb6fd6b6e8d1
EBUILD clang-runtime-17.0.1.9999.ebuild 1351 BLAKE2B 2d30237a865c2abd5b7d2ae2c64167c82103d7abd4ff09b47f26348cac5aed3fe78da821b9d6f12cebdef2abb8c85f5a48834cba65e60091d787886bebaa29fb SHA512 5197003db8e6ed5292d5e07f171922600c9eed2a6c36c5b498b08a850e74376d88730a4c460c9b5456e9379460779ecc345ec824e513651b0985eb6fd6b6e8d1
+EBUILD clang-runtime-17.0.1.ebuild 1442 BLAKE2B ccd97064b84899371758ceab7640d2b9a3104e08dccbefc5523062437cec1358ab68773b96bbc8193d8cd52a2bac65e6687cb150127d953aa49ab7f8cb3dbcea SHA512 9b8639788a2bfab9fea6e717e684c4784ae6719ce8d6bb389d16d836df0b43d108be6c649b9aa17dfa60df7b3f490450d4d51e83dd80707467a844871b97535e
EBUILD clang-runtime-18.0.0.9999.ebuild 1351 BLAKE2B 2d30237a865c2abd5b7d2ae2c64167c82103d7abd4ff09b47f26348cac5aed3fe78da821b9d6f12cebdef2abb8c85f5a48834cba65e60091d787886bebaa29fb SHA512 5197003db8e6ed5292d5e07f171922600c9eed2a6c36c5b498b08a850e74376d88730a4c460c9b5456e9379460779ecc345ec824e513651b0985eb6fd6b6e8d1
EBUILD clang-runtime-18.0.0_pre20230906.ebuild 1351 BLAKE2B 2d30237a865c2abd5b7d2ae2c64167c82103d7abd4ff09b47f26348cac5aed3fe78da821b9d6f12cebdef2abb8c85f5a48834cba65e60091d787886bebaa29fb SHA512 5197003db8e6ed5292d5e07f171922600c9eed2a6c36c5b498b08a850e74376d88730a4c460c9b5456e9379460779ecc345ec824e513651b0985eb6fd6b6e8d1
MISC metadata.xml 661 BLAKE2B 24688c511713ea102b83c71d226d519981b3aee0e05ef7a56d6a80be829efd843194e45cb4fd801f0bb976b6f1976386d6a2b05d2bc907fe2aa42b22b85b7d1f SHA512 2b5ab8783c90795f2e7d1673d876048ed9745f4911fb7a860df56deac13a6dfeba4581a84562eae54eff757c45042ca3fab75c7800313ae61df9ce69780a9294
diff --git a/sys-devel/clang-runtime/clang-runtime-17.0.1.ebuild b/sys-devel/clang-runtime/clang-runtime-17.0.1.ebuild
new file mode 100644
index 000000000000..6483c7c0c78e
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-17.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="${PV%%.*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-16,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}