summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /sys-devel/clang-runtime
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/Manifest1
-rw-r--r--sys-devel/clang-runtime/clang-runtime-6.0.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/Manifest b/sys-devel/clang-runtime/Manifest
index 552a9fad9e50..d8d3a559abc2 100644
--- a/sys-devel/clang-runtime/Manifest
+++ b/sys-devel/clang-runtime/Manifest
@@ -5,6 +5,7 @@ EBUILD clang-runtime-5.0.1-r1.ebuild 815 BLAKE2B 79a99496306fa8a7c9315d5da28e68d
EBUILD clang-runtime-5.0.1.ebuild 685 BLAKE2B 28192550762e053ba121c73c3001d7abd8f3e40cf85c609a51f878a8c5d40e66b10cc3f844a72d7dd552a5cd0d1742cdbf0fbdb8a58b163d34f2f7e6dc11a085 SHA512 5033510813fdeca2497a16556b7e27189f18aa3d04287dd62854883011c4c41257bb897a9130222ff07b8b5ba4b31f206960d35391735c5dad97243471a41027
EBUILD clang-runtime-5.0.2.ebuild 820 BLAKE2B 52c56a71db4514803c8ecc070e21a479bad960fdaa40e3fbd6de2229f6f71c0f5fbbfc2dfc5fee8bcb8570c5e71c73be921cd3fcaabe442551d10ccf9a4736e7 SHA512 bcde7bededdae2f422da56eb68ed862fcafb618b8ce6cd1932a5472e325f0c0231429c7914806915b2f4b579655d0f46d82e19f5f83420d204f53a81a9596e47
EBUILD clang-runtime-6.0.0-r1.ebuild 822 BLAKE2B 1026c7a2622fbeb879699c0a111b76aa4dd50ea375040c90b4dc95d0b8b589a4665e70aa00b8857133eeabd4efcc373e6aae09f043ba12e357c3a07f584710fd SHA512 7b044862d3789d705de7c441043ec3caf820826771916d02ff9120e78185cca51d635051db24be81ac1adbc3f1ed0c632024a0c06216b71ba82335744a3841ef
+EBUILD clang-runtime-6.0.1.ebuild 822 BLAKE2B 1026c7a2622fbeb879699c0a111b76aa4dd50ea375040c90b4dc95d0b8b589a4665e70aa00b8857133eeabd4efcc373e6aae09f043ba12e357c3a07f584710fd SHA512 7b044862d3789d705de7c441043ec3caf820826771916d02ff9120e78185cca51d635051db24be81ac1adbc3f1ed0c632024a0c06216b71ba82335744a3841ef
EBUILD clang-runtime-6.0.9999.ebuild 780 BLAKE2B c10fc2663938e138f6ffba72fbf4bd87fbd93ed89a40992c0960ba18ade6e162544612c921e49d2f03476b758f0269a16375dba129e19b6a3f7ca88d98d2674c SHA512 90fd1d2a1cb62efc6d877efa8a794a6d16ae6032e5af52c50ff2e8ecb8a1a4552d757ec8dda0f905c78a3e068dd848e9155494c84faec649860be4441f69322e
EBUILD clang-runtime-9999.ebuild 780 BLAKE2B e62543ab7d24e09ee7c933283e3445103d943196b02fb4891db1af30aef4ee53c709f8f640b4478fc622fdbb243e981fcafbc42fca7cd1e2d2c56576540dab0a SHA512 ab53bd4228bca6cf4eeb52159433dcb0db57fcc920b6c2e2da4f1b43fa65c0de26d8ad6d7a1655eed44031c1deeeff0acd88f80d107f5bdbc7d776cc66f9af06
MISC metadata.xml 708 BLAKE2B 56cc586deba4a72cc9ebf5d0ac6b9dbb3767b736a96f1c0e4f8d9a715076645be25e42f1c610f55ba69e500bc828d629e7f2253e7c9ed6fd4b01032722bec3c8 SHA512 764eefdff5358c66cad9e8fe18fc7b938c7656268208639cbb92a4b5ae76f7de0dee86a729cc1e6745ddbf7308180885ef99047502e0e040020e738e3d0d1425
diff --git a/sys-devel/clang-runtime/clang-runtime-6.0.1.ebuild b/sys-devel/clang-runtime/clang-runtime-6.0.1.ebuild
new file mode 100644
index 000000000000..9ab9f95ec042
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-6.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="${PV%_*}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"