summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-16 17:15:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-16 17:15:17 +0100
commit6e356edde093fb3589ab7a5859685e85c2873ab0 (patch)
tree5f17cc7bfbddda45678967fdc0a5f9f35fa9c02a /sys-devel/clang-runtime
parentacb0389058b8ef612d851b1ab54fa37376c4b7f7 (diff)
gentoo auto-resync : 16:09:2022 - 17:15:17
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/Manifest1
-rw-r--r--sys-devel/clang-runtime/clang-runtime-16.0.0_pre20220915.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/Manifest b/sys-devel/clang-runtime/Manifest
index c88fb0cd364f..fe346f7db165 100644
--- a/sys-devel/clang-runtime/Manifest
+++ b/sys-devel/clang-runtime/Manifest
@@ -3,4 +3,5 @@ EBUILD clang-runtime-14.0.6.ebuild 760 BLAKE2B 0f6cfb8536569ffe2a09305e710563096
EBUILD clang-runtime-15.0.0-r1.ebuild 766 BLAKE2B db9c38e5d06c9e20d002696b879f61cf79cfe43059224f4a30d9e472a0ecd4a9298d03767e82ac29abcfba283754cb06c1b460e759763dcad130446323af4ff8 SHA512 475cd0538899a4d2a0132f79efbe7fd928a41e7e11798a35b5ba10b3bfcb9bff01b471af5a611f40d3981d2b9d9902fa1bc223199429685de475c38396ffa53e
EBUILD clang-runtime-15.0.0.9999.ebuild 1374 BLAKE2B 1e1242b1780e36b30434fcb31098897fe8c8ca96a92257ac8dedcea380fc90b6161085bb1050a686477bcde8c2d7b29cb0e760da4c206d12a5fe639dd401e58c SHA512 38642226d2ab0435def427f7efed09f4c211104a182e03f1c3e6b37fc4dfc011924dce2978801b463479a48003cf6b74c1ba87913c27a771148368324b65432b
EBUILD clang-runtime-16.0.0.9999.ebuild 1374 BLAKE2B 1e1242b1780e36b30434fcb31098897fe8c8ca96a92257ac8dedcea380fc90b6161085bb1050a686477bcde8c2d7b29cb0e760da4c206d12a5fe639dd401e58c SHA512 38642226d2ab0435def427f7efed09f4c211104a182e03f1c3e6b37fc4dfc011924dce2978801b463479a48003cf6b74c1ba87913c27a771148368324b65432b
+EBUILD clang-runtime-16.0.0_pre20220915.ebuild 1374 BLAKE2B 1e1242b1780e36b30434fcb31098897fe8c8ca96a92257ac8dedcea380fc90b6161085bb1050a686477bcde8c2d7b29cb0e760da4c206d12a5fe639dd401e58c SHA512 38642226d2ab0435def427f7efed09f4c211104a182e03f1c3e6b37fc4dfc011924dce2978801b463479a48003cf6b74c1ba87913c27a771148368324b65432b
MISC metadata.xml 661 BLAKE2B 24688c511713ea102b83c71d226d519981b3aee0e05ef7a56d6a80be829efd843194e45cb4fd801f0bb976b6f1976386d6a2b05d2bc907fe2aa42b22b85b7d1f SHA512 2b5ab8783c90795f2e7d1673d876048ed9745f4911fb7a860df56deac13a6dfeba4581a84562eae54eff757c45042ca3fab75c7800313ae61df9ce69780a9294
diff --git a/sys-devel/clang-runtime/clang-runtime-16.0.0_pre20220915.ebuild b/sys-devel/clang-runtime/clang-runtime-16.0.0_pre20220915.ebuild
new file mode 100644
index 000000000000..c45769b02981
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-16.0.0_pre20220915.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-15,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}