summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /sys-devel/clang-runtime
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/Manifest3
-rw-r--r--sys-devel/clang-runtime/clang-runtime-8.0.9999.ebuild32
-rw-r--r--sys-devel/clang-runtime/clang-runtime-9999.ebuild4
3 files changed, 36 insertions, 3 deletions
diff --git a/sys-devel/clang-runtime/Manifest b/sys-devel/clang-runtime/Manifest
index c1cf2725c5f2..ba7f0755b3d7 100644
--- a/sys-devel/clang-runtime/Manifest
+++ b/sys-devel/clang-runtime/Manifest
@@ -5,5 +5,6 @@ EBUILD clang-runtime-5.0.2.ebuild 820 BLAKE2B 52c56a71db4514803c8ecc070e21a479ba
EBUILD clang-runtime-6.0.1.ebuild 819 BLAKE2B ce5fe6e1f47830366c00f80149adfb9f0ac25742fe57dd1cb1f35c30186a919b89cdb679b342ff1db3ed676bc48c58f28c85b5c74e1adaaab18875293b8be1c1 SHA512 25d88ca2c1d51c0140fbb7572fc45786a61902ff27534ad8e2bd8d12155a69229cadeee3c4827533207a265aa290e829de2141f96bc7d2181c59731ce0fbacfc
EBUILD clang-runtime-7.0.1.ebuild 824 BLAKE2B ea493dd4bc3f7f0d043d6dfffcbcd33f1de6544ca39eacd9f9de57416fed31e6efb4826387b621b14629aef90cc8c73d9d6120e90f5f8f65086de4a7e43eb58c SHA512 875abc4cfc5a4d63016699c7b95b398e8ad1a4bcae6aa90ef198918e9e7d419bfc604ec8e7efc9387f1be36954fd2cd9530487f96b9387e86af8cada2c26ac2a
EBUILD clang-runtime-7.0.9999.ebuild 780 BLAKE2B c911019fb106da9d2c2010921b3e410a83249dc8b1d776a0b98b8cf8024a259d0fb0daaa12558ac994155be97ac831987b18672975cae40b9544828e0369fad2 SHA512 87183412251e82acd10c3a33921ee0e87f24ec9d37feadeb128094684523fb6512efe6216993b0cef4ed19a00138fee372359eedde58752b48cf85c0f10b9888
-EBUILD clang-runtime-9999.ebuild 780 BLAKE2B 97af098ee32a2d42a79dcad29edd1ff7471cb82575ce140cf664d95f2ac805dffdb82d1ee7a6a2b1186e72f594a45a651008494dceea77f496f10b6de5c3acb9 SHA512 d13c63d506cfcda5f1ff4b192b4748d7e4236e89faefd99fc5e30a961bc85931ecdbedd333d83111204cf849e1a0e7f066d845aa38d5b52b911865986173949c
+EBUILD clang-runtime-8.0.9999.ebuild 777 BLAKE2B d63ec3b09f8c2c7d2ff3e3801c3ddefcc59f0086832b96eb014d2a928ffea163c61527e149986bb5f81cb55b466a44bcdee00aead81e1a1dc95ed83133618f13 SHA512 c51f0a4cf46ecb01481e6c4613e399ef3801e7e38963b6b4a94f652a305ebfc45f7afd849f170a4da2333c8372cb27ae129fa054a57f5734ee3cf966c52aeca5
+EBUILD clang-runtime-9999.ebuild 777 BLAKE2B b8dd34360665cae1564b7b6f18d06e5bb7c40d4da1a1315104fa8b530229301ee1a1643c8481657782cae55c6f7921de33cadbc8e46b206d66db438c244b7025 SHA512 0598b3a3381374f377637bacfae6dd8fe8efaba5901692c8a1efb4fe7c2faada61c821602bbfd0f1ba5553642383507acd4ae10207e98fb7bf01cfd78c1f99eb
MISC metadata.xml 708 BLAKE2B 56cc586deba4a72cc9ebf5d0ac6b9dbb3767b736a96f1c0e4f8d9a715076645be25e42f1c610f55ba69e500bc828d629e7f2253e7c9ed6fd4b01032722bec3c8 SHA512 764eefdff5358c66cad9e8fe18fc7b938c7656268208639cbb92a4b5ae76f7de0dee86a729cc1e6745ddbf7308180885ef99047502e0e040020e738e3d0d1425
diff --git a/sys-devel/clang-runtime/clang-runtime-8.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-8.0.9999.ebuild
new file mode 100644
index 000000000000..d9cfd5fe10db
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-8.0.9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+# Note: keep it matching clang-9999 version
+SLOT="8.0.0"
+KEYWORDS=""
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"
diff --git a/sys-devel/clang-runtime/clang-runtime-9999.ebuild b/sys-devel/clang-runtime/clang-runtime-9999.ebuild
index 43a7e11f5ce0..feee635ea14f 100644
--- a/sys-devel/clang-runtime/clang-runtime-9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ SRC_URI=""
LICENSE="metapackage"
# Note: keep it matching clang-9999 version
-SLOT="8.0.0"
+SLOT="9.0.0"
KEYWORDS=""
IUSE="+compiler-rt crt libcxx openmp +sanitize"