summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime/clang-runtime-19.0.0_pre20240302.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-02 17:41:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-02 17:41:59 +0000
commit7c58ecff5764af03b4c65f4115d7b9474e3a5717 (patch)
tree569bdc11cba2d203e04530a1a0dcdc4b52a46de1 /sys-devel/clang-runtime/clang-runtime-19.0.0_pre20240302.ebuild
parent708c31c860cb6292743b80e3371ccccffb0c9bbd (diff)
gentoo auto-resync : 02:03:2024 - 17:41:59
Diffstat (limited to 'sys-devel/clang-runtime/clang-runtime-19.0.0_pre20240302.ebuild')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-19.0.0_pre20240302.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-19.0.0_pre20240302.ebuild b/sys-devel/clang-runtime/clang-runtime-19.0.0_pre20240302.ebuild
new file mode 100644
index 000000000000..323c0b62c062
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-19.0.0_pre20240302.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="${PV%%.*}"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-16,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}