summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime/clang-runtime-18.1.0_rc4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-06 19:06:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-06 19:06:26 +0000
commitf8f68d6f93dd8510c09261f47d4f64cadf303815 (patch)
tree2d317143f2696b93a06c8d26452ea901a1f2fd74 /sys-devel/clang-runtime/clang-runtime-18.1.0_rc4.ebuild
parent0113c4c9eb49e26aee006787c9564c1165909926 (diff)
gentoo auto-resync : 06:03:2024 - 19:06:26
Diffstat (limited to 'sys-devel/clang-runtime/clang-runtime-18.1.0_rc4.ebuild')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-18.1.0_rc4.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-18.1.0_rc4.ebuild b/sys-devel/clang-runtime/clang-runtime-18.1.0_rc4.ebuild
deleted file mode 100644
index 323c0b62c062..000000000000
--- a/sys-devel/clang-runtime/clang-runtime-18.1.0_rc4.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib-build toolchain-funcs
-
-DESCRIPTION="Meta-ebuild for clang runtime libraries"
-HOMEPAGE="https://clang.llvm.org/"
-
-LICENSE="metapackage"
-SLOT="${PV%%.*}"
-IUSE="+compiler-rt libcxx openmp +sanitize"
-REQUIRED_USE="sanitize? ( compiler-rt )"
-
-RDEPEND="
- compiler-rt? (
- ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- sanitize? (
- ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- )
- )
- libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
-"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-16,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}