summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-13 17:49:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-13 17:49:19 +0000
commit06bb974d894b86598af155dc76a6fbd76c4fa30c (patch)
tree363e323b416b8141cedf7b17e890e743d41c4c8a /sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild
parente45f0df9d7f9f5260e69235b8c7c6e00153747f0 (diff)
gentoo auto-resync : 13:01:2023 - 17:49:18
Diffstat (limited to 'sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild
new file mode 100644
index 000000000000..236699295f81
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"