summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-15.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-11 13:38:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-11 13:38:21 +0100
commit59970d0b9cd0a564851f255aebb29a9f76e39c19 (patch)
tree4ed6fa53e3016b6085c92a07d51765f4d8bfbe09 /sys-devel/clang-common/clang-common-15.0.2-r1.ebuild
parent81db58116c7a9c27f54243a4d8f364c7e94c6f36 (diff)
gentoo auto-resync : 11:10:2022 - 13:38:21
Diffstat (limited to 'sys-devel/clang-common/clang-common-15.0.2-r1.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-15.0.2-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.2-r1.ebuild b/sys-devel/clang-common/clang-common-15.0.2-r1.ebuild
index c921dc1cf0c6..515cb176e7bd 100644
--- a/sys-devel/clang-common/clang-common-15.0.2-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.2-r1.ebuild
@@ -26,6 +26,10 @@ PDEPEND="
default-libcxx? ( >=sys-libs/libcxx-${PV} )
default-lld? ( sys-devel/lld )
"
+IDEPEND="
+ !default-compiler-rt? ( sys-devel/gcc-config )
+ !default-libcxx? ( sys-devel/gcc-config )
+"
LLVM_COMPONENTS=( clang/utils )
llvm.org_set_globals
@@ -115,7 +119,8 @@ src_install() {
}
pkg_preinst() {
- if has_version sys-devel/gcc-config; then
+ if has_version -b sys-devel/gcc-config && has_version sys-devel/gcc
+ then
local gcc_path=$(gcc-config --get-lib-path 2>/dev/null)
if [[ -n ${gcc_path} ]]; then
cat >> "${ED}/etc/clang/gentoo-gcc-install.cfg" <<-EOF