summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-15.0.1.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-20 11:23:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-20 11:23:36 +0100
commitc17e7d2a8cc12551a02d28209cd2edbf078d5675 (patch)
treecde162c484c03f53827a78ec75a7f153d18933d3 /sys-devel/clang-common/clang-common-15.0.1.9999.ebuild
parent295483480d7b8ba2fff987fdd32eaa36fe730ce4 (diff)
gentoo auto-resync : 20:09:2022 - 11:23:36
Diffstat (limited to 'sys-devel/clang-common/clang-common-15.0.1.9999.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-15.0.1.9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.1.9999.ebuild b/sys-devel/clang-common/clang-common-15.0.1.9999.ebuild
new file mode 100644
index 000000000000..1285500128bb
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-15.0.1.9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+PDEPEND="
+ sys-devel/clang:*
+"
+
+LLVM_COMPONENTS=( clang/utils )
+llvm.org_set_globals
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}