summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-14.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sys-devel/clang-common/clang-common-14.0.3.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sys-devel/clang-common/clang-common-14.0.3.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-14.0.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-14.0.3.ebuild b/sys-devel/clang-common/clang-common-14.0.3.ebuild
new file mode 100644
index 000000000000..798f9e9fb858
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-14.0.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+
+PDEPEND="
+ sys-devel/clang:*
+"
+
+LLVM_COMPONENTS=( clang/utils )
+llvm.org_set_globals
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}