summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-11.0.1_rc1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /sys-devel/clang-common/clang-common-11.0.1_rc1.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'sys-devel/clang-common/clang-common-11.0.1_rc1.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-11.0.1_rc1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-11.0.1_rc1.ebuild b/sys-devel/clang-common/clang-common-11.0.1_rc1.ebuild
new file mode 100644
index 000000000000..c9abcb48cca8
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-11.0.1_rc1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}