summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'sys-devel/clang-common/clang-common-10.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-10.0.0.9999.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
index d1ce28354dec..d1bfe71d2f80 100644
--- a/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
@@ -3,13 +3,13 @@
EAPI=7
-inherit bash-completion-r1 git-r3
+inherit bash-completion-r1 llvm.org
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
- https://github.com/llvm-mirror/clang.git"
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -18,15 +18,6 @@ IUSE=""
PDEPEND="sys-devel/clang:*"
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' utils/bash-autocomplete.sh
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
src_install() {
- newbashcomp utils/bash-autocomplete.sh clang
+ newbashcomp bash-autocomplete.sh clang
}