summaryrefslogtreecommitdiff
path: root/sys-devel/bmake/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /sys-devel/bmake/files
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'sys-devel/bmake/files')
-rw-r--r--sys-devel/bmake/files/bmake-20201117-tests.patch34
-rw-r--r--sys-devel/bmake/files/bmake-20210206-lib-mk.patch11
2 files changed, 11 insertions, 34 deletions
diff --git a/sys-devel/bmake/files/bmake-20201117-tests.patch b/sys-devel/bmake/files/bmake-20201117-tests.patch
deleted file mode 100644
index 185f45232e1e..000000000000
--- a/sys-devel/bmake/files/bmake-20201117-tests.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- a/unit-tests/Makefile
-+++ b/unit-tests/Makefile
-@@ -168,7 +168,6 @@
- TESTS+= envfirst
- TESTS+= error
- TESTS+= # escape # broken by reverting POSIX changes
--TESTS+= export
- TESTS+= export-all
- TESTS+= export-env
- TESTS+= export-variants
-@@ -255,7 +254,6 @@
- TESTS+= sh-meta-chars
- TESTS+= sh-multi-line
- TESTS+= sh-single-line
--TESTS+= shell-csh
- TESTS+= shell-custom
- .if exists(/bin/ksh)
- TESTS+= shell-ksh
-@@ -287,7 +285,6 @@
- TESTS+= var-op-assign
- TESTS+= var-op-default
- TESTS+= var-op-expand
--TESTS+= var-op-shell
- TESTS+= var-op-sunsh
- TESTS+= var-recursive
- TESTS+= varcmd
-@@ -300,7 +297,6 @@
- TESTS+= varmod-edge
- TESTS+= varmod-exclam-shell
- TESTS+= varmod-extension
--TESTS+= varmod-gmtime
- TESTS+= varmod-hash
- TESTS+= varmod-head
- TESTS+= varmod-ifelse
diff --git a/sys-devel/bmake/files/bmake-20210206-lib-mk.patch b/sys-devel/bmake/files/bmake-20210206-lib-mk.patch
new file mode 100644
index 000000000000..5f860b6f15aa
--- /dev/null
+++ b/sys-devel/bmake/files/bmake-20210206-lib-mk.patch
@@ -0,0 +1,11 @@
+--- a/mk/lib.mk
++++ b/mk/lib.mk
+@@ -170,7 +170,7 @@ LD_solib= lib${LIB}_pic.a
+ .elif ${TARGET_OSNAME} == "Linux"
+ SHLIB_LD = ${CC}
+ # this is ambiguous of course
+-LD_shared=-shared -Wl,"-soname lib${LIB}.so.${SHLIB_MAJOR}"
++LD_shared=-shared -Wl,-soname,lib${LIB}.so.${SHLIB_MAJOR}
+ LD_solib= -Wl,--whole-archive lib${LIB}_pic.a -Wl,--no-whole-archive
+ .if ${COMPILER_TYPE} == "gcc"
+ # Linux uses GNU ld, which is a multi-pass linker