summaryrefslogtreecommitdiff
path: root/sys-devel/bin86/bin86-0.16.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-devel/bin86/bin86-0.16.21.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-devel/bin86/bin86-0.16.21.ebuild')
-rw-r--r--sys-devel/bin86/bin86-0.16.21.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-devel/bin86/bin86-0.16.21.ebuild b/sys-devel/bin86/bin86-0.16.21.ebuild
new file mode 100644
index 000000000000..3c587b03ca5e
--- /dev/null
+++ b/sys-devel/bin86/bin86-0.16.21.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Assembler and loader used to create kernel bootsector"
+HOMEPAGE="http://v3.sk/~lkundrak/dev86/"
+SRC_URI="http://v3.sk/~lkundrak/dev86/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e '/^PREFIX/s:=.*:=$(DESTDIR)/usr:' \
+ -e '/^MANDIR/s:)/man/man1:)/share/man/man1:' \
+ -e '/^INSTALL_OPTS/s:-s::' \
+ -e "/^CFLAGS/s:=.*:=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}:" \
+ -e "/^LDFLAGS/s:=.*:=${LDFLAGS}:" \
+ Makefile || die
+ epatch "${FILESDIR}"/${PN}-0.16.17-amd64-build.patch
+ tc-export CC
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ default
+}