summaryrefslogtreecommitdiff
path: root/sys-devel/automake/automake-1.8.5-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /sys-devel/automake/automake-1.8.5-r5.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'sys-devel/automake/automake-1.8.5-r5.ebuild')
-rw-r--r--sys-devel/automake/automake-1.8.5-r5.ebuild35
1 files changed, 19 insertions, 16 deletions
diff --git a/sys-devel/automake/automake-1.8.5-r5.ebuild b/sys-devel/automake/automake-1.8.5-r5.ebuild
index 241a20422cee..f545e1e2fdee 100644
--- a/sys-devel/automake/automake-1.8.5-r5.ebuild
+++ b/sys-devel/automake/automake-1.8.5-r5.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
-
-inherit eutils
+EAPI=7
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="https://www.gnu.org/software/automake/"
@@ -17,26 +15,30 @@ IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-10
- >=sys-devel/autoconf-2.69
+ >=sys-devel/autoconf-2.69:*
sys-devel/gnuconfig"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.2-infopage-namechange.patch
+ "${FILESDIR}"/${P}-test-fixes.patch #159557
+ "${FILESDIR}"/${PN}-1.9.6-aclocal7-test-sleep.patch #197366
+ "${FILESDIR}"/${PN}-1.9.6-subst-test.patch #222225
+ "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
+ "${FILESDIR}"/${P}-CVE-2009-4029.patch #295357
+ "${FILESDIR}"/${PN}-1.8-perl-5.11.patch
+)
+
src_prepare() {
+ default
export WANT_AUTOCONF=2.5
- epatch "${FILESDIR}"/${PN}-1.8.2-infopage-namechange.patch
- epatch "${FILESDIR}"/${P}-test-fixes.patch #159557
- epatch "${FILESDIR}"/${PN}-1.9.6-aclocal7-test-sleep.patch #197366
- epatch "${FILESDIR}"/${PN}-1.9.6-subst-test.patch #222225
- epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
- epatch "${FILESDIR}"/${P}-CVE-2009-4029.patch #295357
- epatch "${FILESDIR}"/${PN}-1.8-perl-5.11.patch
}
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${ED}"/usr/share/info >/dev/null
- rm -f dir
+ pushd "${ED}"/usr/share/info >/dev/null || die
+ rm -f dir || die
# Rewrite all the references to other pages.
# before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
@@ -58,18 +60,19 @@ slot_info_pages() {
sed -i -e "s:${f}:${d}:g" * || die
done
- popd >/dev/null
+ popd >/dev/null || die
}
src_install() {
default
slot_info_pages
- rm -f "${ED}"/usr/bin/{aclocal,automake}
+ rm -f "${ED}"/usr/bin/{aclocal,automake} || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
local x
for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ dosym ../gnuconfig/config.${x} \
+ /usr/share/${PN}-${SLOT}/config.${x}
done
}