summaryrefslogtreecommitdiff
path: root/sys-devel/automake/automake-1.10.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /sys-devel/automake/automake-1.10.3-r3.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'sys-devel/automake/automake-1.10.3-r3.ebuild')
-rw-r--r--sys-devel/automake/automake-1.10.3-r3.ebuild31
1 files changed, 15 insertions, 16 deletions
diff --git a/sys-devel/automake/automake-1.10.3-r3.ebuild b/sys-devel/automake/automake-1.10.3-r3.ebuild
index 9326962123a8..f70d8537f23a 100644
--- a/sys-devel/automake/automake-1.10.3-r3.ebuild
+++ b/sys-devel/automake/automake-1.10.3-r3.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-any-r1
+EAPI=7
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="https://www.gnu.org/software/automake/"
@@ -14,16 +11,16 @@ LICENSE="GPL-2"
# Use Gentoo versioning for slotting.
SLOT="${PV:0:4}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
+IUSE=""
+RESTRICT="test"
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-10
>=sys-devel/autoconf-2.69:*
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
- sys-apps/help2man
- test? ( ${PYTHON_DEPS} )"
+ sys-apps/help2man"
+BDEPEND="app-arch/gzip"
PATCHES=(
"${FILESDIR}"/${PN}-1.10-perl-5.16.patch #424453
@@ -31,20 +28,15 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.13-perl-escape-curly-bracket-r1.patch
)
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
src_prepare() {
default
export WANT_AUTOCONF=2.5
- chmod a+rx tests/*.test
}
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${ED%/}"/usr/share/info >/dev/null || die
+ pushd "${ED}"/usr/share/info >/dev/null || die
rm -f dir || die
# Rewrite all the references to other pages.
@@ -79,12 +71,19 @@ src_install() {
for x in aclocal automake ; do
help2man "perl -Ilib ${x}" > ${x}-${SLOT}.1
doman ${x}-${SLOT}.1
- rm -f "${ED%/}"/usr/bin/${x}
+ rm -f "${ED}"/usr/bin/${x}
done
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ dosym ../gnuconfig/config.${x} \
+ /usr/share/${PN}-${SLOT}/config.${x}
done
+
+ # Avoid QA message about pre-compressed file in docs
+ local tarfile="${ED}/usr/share/doc/${PF}/amhello-1.0.tar.gz"
+ if [[ -f "${tarfile}" ]] ; then
+ gunzip "${tarfile}" || die
+ fi
}