summaryrefslogtreecommitdiff
path: root/sys-devel/autoconf/autoconf-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 21:51:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 21:51:32 +0100
commitc55c2cf7b5e5e8ce7f21c53ee7996c2ea918279d (patch)
treee8bb447a647aa737a0da2ede957972eb72e7dcd4 /sys-devel/autoconf/autoconf-9999.ebuild
parentd41bd0acd3d0cd850cdd815b12e69ee2c89c5697 (diff)
gentoo auto-resync : 28:03:2023 - 21:51:31
Diffstat (limited to 'sys-devel/autoconf/autoconf-9999.ebuild')
-rw-r--r--sys-devel/autoconf/autoconf-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/sys-devel/autoconf/autoconf-9999.ebuild b/sys-devel/autoconf/autoconf-9999.ebuild
index 1bd34bcdca1a..d343e10dd0fe 100644
--- a/sys-devel/autoconf/autoconf-9999.ebuild
+++ b/sys-devel/autoconf/autoconf-9999.ebuild
@@ -30,7 +30,7 @@ DESCRIPTION="Used to create autoconfiguration files"
HOMEPAGE="https://www.gnu.org/software/autoconf/autoconf.html"
LICENSE="GPL-3+"
-SLOT="${PV/_*}"
+SLOT="$(ver_cut 1-2)"
IUSE="emacs"
BDEPEND="
@@ -47,6 +47,15 @@ RDEPEND="
PDEPEND="emacs? ( app-emacs/autoconf-mode )"
src_prepare() {
+ if [[ ${PV} == *9999 ]] ; then
+ # Avoid the "dirty" suffix in the git version by generating it
+ # before we run later stages which might modify source files.
+ local ver=$(./build-aux/git-version-gen .tarball-version)
+ echo "${ver}" > .tarball-version || die
+
+ autoreconf -f -i || die
+ fi
+
# usr/bin/libtool is provided by binutils-apple, need gnu libtool
if [[ ${CHOST} == *-darwin* ]] ; then
PATCHES+=( "${FILESDIR}"/${PN}-2.71-darwin.patch )
@@ -55,13 +64,6 @@ src_prepare() {
# Save timestamp to avoid later makeinfo call
touch -r doc/{,old_}autoconf.texi || die
- local pdir
- for pdir in "${WORKDIR}"/{upstream_,}patches ; do
- if [[ -d "${pdir}" ]] ; then
- eapply ${pdir}
- fi
- done
-
toolchain-autoconf_src_prepare
# Restore timestamp to avoid makeinfo call