summaryrefslogtreecommitdiff
path: root/sys-devel/autoconf-wrapper/autoconf-wrapper-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-23 01:07:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-23 01:07:24 +0000
commit57c2e006d0af9ab77ced676461d7100cade4a716 (patch)
treefedd61a96505af97dea0e78425b1b7a70b813a46 /sys-devel/autoconf-wrapper/autoconf-wrapper-99999999.ebuild
parent664924d8659185e3b43f99ee8a0b88177efb93dc (diff)
gentoo auto-resync : 23:11:2022 - 01:07:24
Diffstat (limited to 'sys-devel/autoconf-wrapper/autoconf-wrapper-99999999.ebuild')
-rw-r--r--sys-devel/autoconf-wrapper/autoconf-wrapper-99999999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-devel/autoconf-wrapper/autoconf-wrapper-99999999.ebuild b/sys-devel/autoconf-wrapper/autoconf-wrapper-99999999.ebuild
new file mode 100644
index 000000000000..9c6f006f4f4a
--- /dev/null
+++ b/sys-devel/autoconf-wrapper/autoconf-wrapper-99999999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="autotools-wrappers-at-${PV}"
+
+DESCRIPTION="Wrapper for autoconf to manage multiple autoconf versions"
+HOMEPAGE="https://gitweb.gentoo.org/proj/autotools-wrappers.git"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI=" https://anongit.gentoo.org/git/proj/autotools-wrappers.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/autotools-wrappers.git/snapshot/${MY_P}.tar.gz"
+ #SRC_URI="https://dev.gentoo.org/~vapier/dist/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_install() {
+ exeinto /usr/$(get_libdir)/misc
+ doexe ac-wrapper.sh
+
+ dodir /usr/bin
+
+ local x=
+ for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
+ dosym -r /usr/$(get_libdir)/misc/ac-wrapper.sh /usr/bin/${x}
+ done
+}