summaryrefslogtreecommitdiff
path: root/sys-cluster
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-20 00:10:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-20 00:10:57 +0100
commitd6ca4e4f90cb75c323b5988eefa96a04c0d36908 (patch)
tree8197fc88451976470c871e991b75a9d40c240270 /sys-cluster
parente8df704cf9b5e9e517317b8912377c0a8ca0d11e (diff)
gentoo auto-resync : 20:06:2024 - 00:10:56
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/Manifest.gzbin11364 -> 11361 bytes
-rw-r--r--sys-cluster/teleport/Manifest1
-rw-r--r--sys-cluster/teleport/teleport-9999.ebuild50
3 files changed, 0 insertions, 51 deletions
diff --git a/sys-cluster/Manifest.gz b/sys-cluster/Manifest.gz
index 292308e9853e..d44cfdd51d20 100644
--- a/sys-cluster/Manifest.gz
+++ b/sys-cluster/Manifest.gz
Binary files differ
diff --git a/sys-cluster/teleport/Manifest b/sys-cluster/teleport/Manifest
index c0339846d654..bd034897a96b 100644
--- a/sys-cluster/teleport/Manifest
+++ b/sys-cluster/teleport/Manifest
@@ -5,5 +5,4 @@ AUX teleport.service.conf 90 BLAKE2B 7f12f281d73ac6573c882a7910e400f901ff6392e0c
AUX teleport.yaml 10168 BLAKE2B c84b33deabb616f58eb7b42224040405eb524749a98647e94bde8d3044e39ef2cd79baff6e8135e61f4b5db86ebc20f7f24b819459b944427386140d716490b2 SHA512 9893764ff11d0c499b30b5dd41c2e56dcf5719baa2d172ee5d500b5c9f7f81af9901f8cd2de8799f5520793f5be6755efc757c518659eca5d1ef89f9fb7a9e24
DIST teleport-4.1.4.tar.gz 42353194 BLAKE2B 905babaa899b80816b826a920f75dde55619ef7b476da6b3277347128a7301853241abcda852617363bfeb6fa432ef8f49d4b9444cde79e8e38ba9a79e2ec6dc SHA512 5aa8e872802924e03839d4311b346cf1ef00c786e77a62e43a7b182c49f8cee7430e153c5d9ce8400beba332c715d21cdffef7c75be86992e0290d3795b38f12
EBUILD teleport-4.1.4.ebuild 1255 BLAKE2B 8d8e22edf8d468fc5348561291e273e72b40fd8a880a31f9f03464b745e813af576dd3ce8c70b4da638e7b4392b4e07d4ff8dc502b20c0c1f9d70fbcda90ed86 SHA512 1bc10a27fd1d9375f1a109b0f5bdd69d45c7399ab9a6c0cd8777c244f791cf01967847d3668a86723784588612539687f11a9bc1850fe79b92552d7b953c2c13
-EBUILD teleport-9999.ebuild 1243 BLAKE2B 58785b5537bcf47366cafe481ba1855e1acf1e6f4f1b5939195b58d3b3fced5690d9c0933c856111b834df50e9ab857d42ba826eb9664c2f51ee740c5a6e9442 SHA512 54b817d0e5be7872af7c52982842f94dee9573922c5450cd89aa3c507fc81d06e56eedcc505fda16ab0b96866184f5a226a7de2a745d121b9205ddaeb912f32a
MISC metadata.xml 661 BLAKE2B 56ff8cb6596f39f02d0dd72b3de721eafab2efc0b9a7262edc6e2a68fdc3fea5c12bb1792f8cdf1bb4de93f98d5b9f3ffcb6e282b5c971d7f24c4374bd2d4cca SHA512 d0c452dfdb0a60c6f0287795206dc2dd97a2a34e7e8da8cdc3f63d70edd005be425321a05b8c0f428b0e51efb91ddad1396be631e4ee3f1fa31ace5b79f335b4
diff --git a/sys-cluster/teleport/teleport-9999.ebuild b/sys-cluster/teleport/teleport-9999.ebuild
deleted file mode 100644
index a82f2fc86c92..000000000000
--- a/sys-cluster/teleport/teleport-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit golang-build systemd
-
-DESCRIPTION="Modern SSH server for teams managing distributed infrastructure"
-HOMEPAGE="https://gravitational.com/teleport"
-
-EGO_PN="github.com/gravitational/${PN}/..."
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3 golang-vcs
- EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
-else
- inherit golang-vcs-snapshot
- SRC_URI="https://github.com/gravitational/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm"
-fi
-
-IUSE="pam"
-LICENSE="Apache-2.0 MIT BSD ISC"
-RESTRICT="test strip"
-SLOT="0"
-
-BDEPEND="app-arch/zip"
-RDEPEND="pam? ( sys-libs/pam )"
-
-src_compile() {
- BUILDFLAGS="" GOPATH="${S}" emake -j1 -C src/${EGO_PN%/*} full
-}
-
-src_install() {
- keepdir /var/lib/${PN} /etc/${PN}
- dobin src/${EGO_PN%/*}/build/{tsh,tctl,teleport}
-
- insinto /etc/${PN}
- doins "${FILESDIR}"/${PN}.yaml
-
- newinitd "${FILESDIR}"/${PN}.init.d ${PN}
- newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
-
- systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
- systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
-}
-
-src_test() {
- BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*} test
-}