summaryrefslogtreecommitdiff
path: root/sys-cluster/zookeepercli/zookeepercli-1.0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /sys-cluster/zookeepercli/zookeepercli-1.0.12.ebuild
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'sys-cluster/zookeepercli/zookeepercli-1.0.12.ebuild')
-rw-r--r--sys-cluster/zookeepercli/zookeepercli-1.0.12.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-cluster/zookeepercli/zookeepercli-1.0.12.ebuild b/sys-cluster/zookeepercli/zookeepercli-1.0.12.ebuild
new file mode 100644
index 000000000000..13a626b00c26
--- /dev/null
+++ b/sys-cluster/zookeepercli/zookeepercli-1.0.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/outbrain/zookeepercli"
+EGO_VENDOR=(
+ "github.com/outbrain/golib ab954725f502c2be1491afadbbc66da2f99a45ae"
+ "github.com/samuel/go-zookeeper c4fab1ac1bec58281ad0667dc3f0907a9476ac47"
+)
+
+inherit golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+EGIT_COMMIT="v${PV}"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_VENDOR_URI}"
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+DESCRIPTION="Simple, lightweight, dependable CLI for ZooKeeper"
+HOMEPAGE="https://github.com/outbrain/zookeepercli"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.9:="
+
+src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #678960
+ GOPATH="${WORKDIR}/${P}" \
+ go build -v -work -x ${EGO_BUILD_FLAGS} \
+ -o "${S}/bin/zookeepercli" \
+ ./go/cmd/zookeepercli.go || die
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+}