summaryrefslogtreecommitdiff
path: root/sys-cluster/vzctl/vzctl-4.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 23:47:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 23:47:37 +0100
commit02930d1eb5af78d32b1597af6af24163895d9e0f (patch)
tree7908188ca5a80d7ff557ebc70fe3bdcbf2875832 /sys-cluster/vzctl/vzctl-4.9.4.ebuild
parent54654470d999265b5a0010be7190e8a9993b1840 (diff)
gentoo auto-resync : 11:05:2023 - 23:47:37
Diffstat (limited to 'sys-cluster/vzctl/vzctl-4.9.4.ebuild')
-rw-r--r--sys-cluster/vzctl/vzctl-4.9.4.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/sys-cluster/vzctl/vzctl-4.9.4.ebuild b/sys-cluster/vzctl/vzctl-4.9.4.ebuild
deleted file mode 100644
index fc75cfa78c5f..000000000000
--- a/sys-cluster/vzctl/vzctl-4.9.4.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 optfeature udev
-
-DESCRIPTION="OpenVZ ConTainers control utility"
-HOMEPAGE="https://openvz.org/"
-SRC_URI="https://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-IUSE="+ploop +vzmigrate"
-
-BDEPEND="virtual/pkgconfig"
-RDEPEND="
- >=dev-libs/libcgroup-0.38
- net-firewall/iptables
- sys-apps/attr
- sys-apps/ed
- >=sys-apps/iproute2-3.3.0
- >=sys-fs/vzquota-3.1
- virtual/udev
- ploop? (
- dev-libs/libxml2
- sys-block/parted
- >=sys-cluster/ploop-1.13
- sys-fs/quota
- )
- vzmigrate? (
- app-arch/tar[xattr,acl]
- net-misc/openssh
- net-misc/rsync[xattr,acl]
- net-misc/bridge-utils
- app-alternatives/awk
- )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-glibc225.patch
- "${FILESDIR}"/${P}-glibc225-2.patch
-)
-
-src_prepare() {
- # Set default OSTEMPLATE on gentoo
- sed -i -e 's:=redhat-:=gentoo-:' etc/dists/default || die 'sed on etc/dists/default failed'
- # Set proper udev directory
- sed -i -e "s:/lib/udev:$(get_udevdir):" src/lib/dev.c || die 'sed on src/lib/dev.c failed'
-
- default
-}
-
-src_configure() {
- econf \
- --localstatedir=/var \
- --enable-udev \
- --enable-bashcomp \
- --enable-logrotate \
- --with-vz \
- $(use_with ploop) \
- --with-cgroup
-}
-
-src_install() {
- emake DESTDIR="${D}" udevdir="$(get_udevdir)"/rules.d install install-gentoo
-
- # install the bash-completion script into the right location
- rm -rf "${ED}"/etc/bash_completion.d || die
- newbashcomp etc/bash_completion.d/vzctl.sh ${PN}
-
- # We need to keep some dirs
- keepdir /vz/{dump,lock,root,private,template/cache}
- keepdir /etc/vz/names /var/lib/vzctl/veip
-}
-
-pkg_postinst() {
- einfo "This vzctl release requires a kernel above 2.6.32.92"
-
- optfeature "Checkpoint suspend/restore support (experimental)" sys-process/criu
- optfeature "Compressed .xz templates" app-arch/xz-utils
- optfeature "Signed templates" app-crypt/gnupg
-}