summaryrefslogtreecommitdiff
path: root/sys-cluster/ucx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
commit171a011ad3a131671aeb5a98b9e3adf219ad2865 (patch)
tree0c877a3d1a37f10e37ad7168cfc52054aa0948a7 /sys-cluster/ucx
parent75fc75ae1f0481ffdb78450e801a9b443ba641bd (diff)
gentoo resync : 02.04.2018
Diffstat (limited to 'sys-cluster/ucx')
-rw-r--r--sys-cluster/ucx/Manifest3
-rw-r--r--sys-cluster/ucx/metadata.xml12
-rw-r--r--sys-cluster/ucx/ucx-1.2.2.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/sys-cluster/ucx/Manifest b/sys-cluster/ucx/Manifest
new file mode 100644
index 000000000000..03ef93cbf0a9
--- /dev/null
+++ b/sys-cluster/ucx/Manifest
@@ -0,0 +1,3 @@
+DIST ucx-1.2.2.tar.gz 1513611 BLAKE2B 488b9b3cecc2c617b1209036e1342e4378459db6a5e93eab1d88dfe80cb0d9c8013c767413206f0fbd0105557ed89994ab510421068d709101336a7b3d2eac5e SHA512 515c382826310b9aa7179ab19ceb76a881a41e6786514219b7f703c6144fa57ca141bceb3b80523ae1b4e2a4b13e9abcb9df063612b376d894c5cd81cdc00571
+EBUILD ucx-1.2.2.ebuild 552 BLAKE2B d8f6124348211b96de3077f6fc11157f60f868806300d6955ddbc10c4e338594e7f0558003a1407d66d9b762364d305140f129902c796bde54370bfb38030698 SHA512 68329d0308cd3eac6dbef3309e1ffee57af3c219c8ff9a3a3d24a3ddf882c3a5671f21a0fdc50188f651bda8486053fe644d84c296d3efca483acc90cf4ec95b
+MISC metadata.xml 362 BLAKE2B 63b27b82f640cbea668c63054f8a9cb64aa56adf57d9e54022d66f7f2fb8b18d2c3c6cfa9f24c3edb89c237d92648dbc9c4cf36dba0133f57bdff7afe64173fb SHA512 a023b70c13acc10f06ef6a63a922044b3ed7991d2701c087d84c17661b5d976de305ab7d16c8225f0f24d4868cf603f949ab12638cb8a0e9b6af3aa9333b6b91
diff --git a/sys-cluster/ucx/metadata.xml b/sys-cluster/ucx/metadata.xml
new file mode 100644
index 000000000000..d11a30befa7f
--- /dev/null
+++ b/sys-cluster/ucx/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cluster@gentoo.org</email>
+ <name>Gentoo Cluster Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/ucx/ucx-1.2.2.ebuild b/sys-cluster/ucx/ucx-1.2.2.ebuild
new file mode 100644
index 000000000000..0b581f7bf566
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="http://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_prepare() {
+ default
+ sed \
+ -e '/^BASE_CFLAGS/s:=.*:=:g' \
+ -i config/m4/compiler.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt
+}