summaryrefslogtreecommitdiff
path: root/sys-cluster/ucx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /sys-cluster/ucx
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'sys-cluster/ucx')
-rw-r--r--sys-cluster/ucx/Manifest2
-rw-r--r--sys-cluster/ucx/ucx-1.5.2.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-cluster/ucx/Manifest b/sys-cluster/ucx/Manifest
index 6a1cdc7097a7..7eae9509cae6 100644
--- a/sys-cluster/ucx/Manifest
+++ b/sys-cluster/ucx/Manifest
@@ -1,5 +1,7 @@
DIST ucx-1.2.2.tar.gz 1513611 BLAKE2B 488b9b3cecc2c617b1209036e1342e4378459db6a5e93eab1d88dfe80cb0d9c8013c767413206f0fbd0105557ed89994ab510421068d709101336a7b3d2eac5e SHA512 515c382826310b9aa7179ab19ceb76a881a41e6786514219b7f703c6144fa57ca141bceb3b80523ae1b4e2a4b13e9abcb9df063612b376d894c5cd81cdc00571
DIST ucx-1.3.0.tar.gz 1707317 BLAKE2B 740ab240663a26fde8abe631416dae6233febf3c587ba6bb7b27a9cb0aa041540ce71e106bb3c5618a719de66d479055961908b67125df61a4c7696999c0affb SHA512 0a2e32985e0225fc4ad15dbb1c422dba1d5552638e7329d67572924502e61e1a481ce30cde5ccc83c663fb4ec643df83efc08aed164dfbce6cf38d66a16b3e42
+DIST ucx-1.5.2.tar.gz 1844416 BLAKE2B 2e0296e34d8116a79c545fb3371dda1746517a18cc75f94da5d1f9420c7a74752839d5a3a07a61a2e91021baa87a26d02ab24554316351db9ba76721a18a5244 SHA512 7f11014eb26df342fc8f0914d323f08f4c19ea21e98e18f0a4ec18b7004299687f91daa8ee654ecee716ece6d4d6de5c9714c548768b1d44551b6be6195e2e9b
EBUILD ucx-1.2.2-r1.ebuild 659 BLAKE2B d652d30689c81d90d88432367f10693cfbeb925f96bac67891ab16f662ca8f801e9bca911ee1f566de0651ca06e8e7bb989bcce6c73c2b5a5a8827e8a8002d37 SHA512 79d4f2a0241bbe6c7f50df95e746b7cbf7a060b07cbaf79deffeb46d78c2edea17c9bb99b9c9f18308dceb3d3630d3881c5e0300db8761b0a2c9d20a349e32c6
EBUILD ucx-1.3.0.ebuild 523 BLAKE2B 8da1295c6304291a475ce5459cbf13e7ede6103c091aad579bfacaf3b475c5220161ffa2132db8d07438d3c97e8454414a05a866fc80b44a20be18be2b144cea SHA512 b01c4e399bbf1a1f81fa89324badab7a791399fbfd25a3da71ae433858fbb744ce48891753bc866d34913e702e517a7a285fe9ee5b626dccb108126466b0217c
+EBUILD ucx-1.5.2.ebuild 607 BLAKE2B 8cda89f9d587ec46746d17cb209b1315cb86978ffebea050e6e8f486b9b9047bba6e668f9ff4925a612113c5f4900ccb45c2102fdb92127c4a703a68185f1223 SHA512 4bf9bb352b9748d2b73fe2088ad1dd5b6f20f8707980421b772f74ca49f60f21463f82436776c38548b0a20a7f6b3f13dadeb366df2460c123ecbbfd09a6e2ee
MISC metadata.xml 443 BLAKE2B 8dd81ad5620da74decf43d97ef37e29bbbac1d3016ac11ee7dc7368bacff1b17edb284bcfbf45000925a4837eb144b882b5cbc17dd99c4a24a429cd516ef6902 SHA512 3e82b7bc2aec1bf3cb98e70e20059e1f3575c5342c6163d4816064b9ff648671add1780b9524fbb14f2bf9de50ed58b09ae192b30732d25ad36ca63e2d92dc3a
diff --git a/sys-cluster/ucx/ucx-1.5.2.ebuild b/sys-cluster/ucx/ucx-1.5.2.ebuild
new file mode 100644
index 000000000000..55ec075ba427
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="http://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ numa? ( sys-process/numactl )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}
+
+src_compile() {
+ BASE_CFLAGS="" emake
+}