summaryrefslogtreecommitdiff
path: root/sys-cluster/singularity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /sys-cluster/singularity
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest2
-rw-r--r--sys-cluster/singularity/singularity-3.7.4.ebuild73
2 files changed, 0 insertions, 75 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index b32f84d8f1c5..ad831a1c2115 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,5 +1,3 @@
-DIST singularity-3.7.4.tar.gz 6446703 BLAKE2B f9263a18c138cffa116ab06d59533948e48500fad69917598adc36b47fb0b8bf81e868ea924d1cd0e39ca6345a2fdc38a1c9788944729a43c4c8b63bbe82a184 SHA512 a02d8e5c3c229e454c7736173cbe3709ccaafb0ffedcf537501eb091cd3ee54899542e0c6e1221f35dcffbaf48d27be7e91a9bd510bdaacfd8a2285ea41e6f3d
DIST singularity-3.8.0.tar.gz 7892955 BLAKE2B a75c9a5646cf5bfcc906bdda0e72e062787f6694322ca62ff329c63dfad051edc6c751e4e58cf01476a133947d87ad6230ba60e2d7b7da75ba654486a6c8d48c SHA512 b1e3dc673fbf58d8fa13bea4c67114d1abf0f17e86f1958f585795374107f6b18dd854899b4a574dc3e4d8d4abf4177c26e63c7c3436ae1d35c66331f1630272
-EBUILD singularity-3.7.4.ebuild 1920 BLAKE2B dfb08d92fd548420df98f8f7a231840b13c6fcab2f74a673c324a2f123a212128eb4a0968f3834b6a2b11c5239b42ce80f0f78906bec6de40a5f81efa96f771e SHA512 e420cac5eea34e0d6dab96bbd02dfacfc7fcea64469fa2d542dd474249f88fa37367792d7d124b7fbe923da60ef66c817b4f4a69c50a722c8ed5166a5a48c48d
EBUILD singularity-3.8.0.ebuild 1900 BLAKE2B a24c10ad485b5359a304caf1c85dcd1529e41d50070f842b9d36f1ef79c76edd51ed44f8bceddeea729038eb299e1a917036fef34f036413255033e3e4c0d3ae SHA512 32764eddc65b36a265c7527852b4b1709dca3f1cc17ad38ea75950fd2972643f0f13238df1e481fe392762ef6755e83707b64037b36f73dd18a923ee0f28058c
MISC metadata.xml 451 BLAKE2B 0cca32721561e4100348cd884b88edad067a426736df27d4be6926525f9dd1315387dbefff84b983e69ab1972a44cd3a3a2c643bae676b413dab3482005d4ceb SHA512 da6f640f7df71bfe98fdabfe8ea69b1929b80b3c23d869dc496515a76d3f76c5d89d38843faf850184ddd7f624dd1e821dd50103f92e81aeb620a4bcd7151609
diff --git a/sys-cluster/singularity/singularity-3.7.4.ebuild b/sys-cluster/singularity/singularity-3.7.4.ebuild
deleted file mode 100644
index c018b5042e0b..000000000000
--- a/sys-cluster/singularity/singularity-3.7.4.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info toolchain-funcs
-
-DESCRIPTION="Application containers for Linux"
-HOMEPAGE="https://sylabs.io"
-SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="examples +network +suid"
-
-# Do not complain about CFLAGS etc. since go projects do not use them.
-QA_FLAGS_IGNORED='.*'
-
-COMMON="sys-libs/libseccomp"
-BDEPEND="virtual/pkgconfig"
-DEPEND="${COMMON}
- >=dev-lang/go-1.13.0
- app-crypt/gpgme
- dev-libs/openssl
- sys-apps/util-linux
- sys-fs/cryptsetup"
-RDEPEND="${COMMON}
- sys-fs/squashfs-tools"
-
-CONFIG_CHECK="~SQUASHFS"
-
-S=${WORKDIR}/${PN}
-
-src_configure() {
- local myconfargs=(
- -c "$(tc-getBUILD_CC)" \
- -x "$(tc-getBUILD_CXX)" \
- -C "$(tc-getCC)" \
- -X "$(tc-getCXX)" \
- --prefix=/usr \
- --sysconfdir=/etc \
- --runstatedir=/run \
- --localstatedir=/var \
- $(usex network "" "--without-network") \
- $(usex suid "" "--without-suid")
- )
- ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
-}
-
-src_compile() {
- emake -C builddir
-}
-
-src_install() {
- emake DESTDIR="${ED}" -C builddir install
- keepdir /var/singularity/mnt/session
-
- # As of version 3.5.3 this seems to be very much broken, affecting
- # commands which have got nothing to do with singularity (example:
- # completion on 'udisks mount -b /dev/' rejects all files from that
- # directory other than 'autofs'). Moreover, this should go into
- # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
- # Hopefully temporary, which is why we delete this at install time
- # instead of patching build scripts not to generate bash-completion
- # data in the first place.
- rm -rf "${ED}"/etc/bash_completion.d || die
-
- dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
- if use examples; then
- dodoc -r examples
- fi
-}