summaryrefslogtreecommitdiff
path: root/sys-cluster/singularity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /sys-cluster/singularity
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest2
-rw-r--r--sys-cluster/singularity/singularity-3.6.3.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index dafff31ba50a..05e3becea769 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,3 +1,5 @@
DIST singularity-3.6.2.tar.gz 5933938 BLAKE2B 86b79687ef7591a255d01b83e857d87b7ab45aa9a84c40a7c90b493c0fc04cb33ff4f1616f38c5178e22ff1b19d390ab3b96f0fb05d6c66534e60d9ef2d7ea33 SHA512 fed2ebd286a3f250d8f4a7677e4bc0b13ec9b2e2eacff91c9a7f6efe6abc766a2d1b713bc291f0239585d5dacd5d4657309ef81eceb77f849f01be934a76499f
+DIST singularity-3.6.3.tar.gz 5935146 BLAKE2B ff5c572c016fac36032e595765319dcdff65975f2036da1222b7b74911def0bc85a2cc86ad50cb0994397251e35d629b52b59f9d6894608448d23ceba808db5c SHA512 2c3342197a5075b89eb37bdf9127f9abaf3676f67dae0d164813f94e84f12b9f51f22eafd2e81a82e686622d93f90bcdf6f62c051903a2f122f960d0c116d5b1
EBUILD singularity-3.6.2.ebuild 1921 BLAKE2B 5ebd469923ae0c46f60db2197c103d9e7177afdda7bec141673e102c0911486cd88697fbddd89e54e23e5871cf0d8e660cce81f72ce6987b0a8465a624404241 SHA512 e875a95330b35d61cd78261400cca0b2610e3e530f4aaebc3f00af0623986ea448f3fc144eff4fd2e8659fcbe56808e00bf9a4a12fbef88dfa6b172e3a96593f
+EBUILD singularity-3.6.3.ebuild 1921 BLAKE2B 5ebd469923ae0c46f60db2197c103d9e7177afdda7bec141673e102c0911486cd88697fbddd89e54e23e5871cf0d8e660cce81f72ce6987b0a8465a624404241 SHA512 e875a95330b35d61cd78261400cca0b2610e3e530f4aaebc3f00af0623986ea448f3fc144eff4fd2e8659fcbe56808e00bf9a4a12fbef88dfa6b172e3a96593f
MISC metadata.xml 451 BLAKE2B 0cca32721561e4100348cd884b88edad067a426736df27d4be6926525f9dd1315387dbefff84b983e69ab1972a44cd3a3a2c643bae676b413dab3482005d4ceb SHA512 da6f640f7df71bfe98fdabfe8ea69b1929b80b3c23d869dc496515a76d3f76c5d89d38843faf850184ddd7f624dd1e821dd50103f92e81aeb620a4bcd7151609
diff --git a/sys-cluster/singularity/singularity-3.6.3.ebuild b/sys-cluster/singularity/singularity-3.6.3.ebuild
new file mode 100644
index 000000000000..23232305c173
--- /dev/null
+++ b/sys-cluster/singularity/singularity-3.6.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="https://sylabs.io"
+SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network +suid"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+COMMON="sys-libs/libseccomp"
+BDEPEND="virtual/pkgconfig"
+DEPEND="${COMMON}
+ >=dev-lang/go-1.13.0
+ app-crypt/gpgme
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup"
+RDEPEND="${COMMON}
+ sys-fs/squashfs-tools"
+
+CONFIG_CHECK="~SQUASHFS"
+
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --runstatedir=/run \
+ --localstatedir=/var \
+ $(usex network "" "--without-network") \
+ $(usex suid "" "--without-suid")
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -C builddir install
+ keepdir /var/singularity/mnt/session
+
+ # As of version 3.5.3 this seems to be very much broken, affecting
+ # commands which have got nothing to do with singularity (example:
+ # completion on 'udisks mount -b /dev/' rejects all files from that
+ # directory other than 'autofs'). Moreover, this should go into
+ # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
+ # Hopefully temporary, which is why we delete this at install time
+ # instead of patching build scripts not to generate bash-completion
+ # data in the first place.
+ rm -rf "${ED}"/etc/bash_completion.d || die
+
+ dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
+ if use examples; then
+ dodoc -r examples
+ fi
+}