summaryrefslogtreecommitdiff
path: root/sys-cluster/singularity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /sys-cluster/singularity
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest2
-rw-r--r--sys-cluster/singularity/singularity-3.8.4.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index a6d181d8b02e..d3191145710f 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,5 +1,7 @@
DIST singularity-3.8.0.tar.gz 7892955 BLAKE2B a75c9a5646cf5bfcc906bdda0e72e062787f6694322ca62ff329c63dfad051edc6c751e4e58cf01476a133947d87ad6230ba60e2d7b7da75ba654486a6c8d48c SHA512 b1e3dc673fbf58d8fa13bea4c67114d1abf0f17e86f1958f585795374107f6b18dd854899b4a574dc3e4d8d4abf4177c26e63c7c3436ae1d35c66331f1630272
DIST singularity-3.8.3.tar.gz 7948604 BLAKE2B 67c8f4e52faf46a25c1bc16d4f05100f92cfb67b111898bebaeed827bb545f9d44fc3aaae99cbea020ec934c7dd3412b119a3f7f3f003f3e09a5e86dd2816957 SHA512 ede69bfa6602d75f67354afc215a1cf51db769df052662b77a8f1ac88cf580f13683190231452611ba618cda0e63af746dcdf59ab41611a9035bd199f8b50ec5
+DIST singularity-3.8.4.tar.gz 7959412 BLAKE2B 17786ef9c5a7d3ba0a6494253b5ad5972e89882a5e31aa9da14e62fbc5e8b515e39b22a5832fddb3fbd9cec74caabcb49264541412bc33955643d708ff7a7dc2 SHA512 21170fcea6d49edd827b000b7885fd4bd4a35fc4367a68f1358f45f181fe6b09eae6336bb02007948c20841483c1b74831faca8408cd3f2982be780712967c55
EBUILD singularity-3.8.0.ebuild 1900 BLAKE2B a24c10ad485b5359a304caf1c85dcd1529e41d50070f842b9d36f1ef79c76edd51ed44f8bceddeea729038eb299e1a917036fef34f036413255033e3e4c0d3ae SHA512 32764eddc65b36a265c7527852b4b1709dca3f1cc17ad38ea75950fd2972643f0f13238df1e481fe392762ef6755e83707b64037b36f73dd18a923ee0f28058c
EBUILD singularity-3.8.3.ebuild 1909 BLAKE2B 345f4286e94ab41b16beb32498f84b10e9c53b70a94dd59f3be44f0762785ddb514dcef6c688541a11d02fa36b01426029a3f6802f175fbb34e6e8cafa789a52 SHA512 21c185762d6aa45e4e15301b3c3bfff41fa4d5ec46f79e4f8647d9a79debfc6f6852603a7f64b1ef547dd927c4e8c72646a552a21483ac88e8a595c6f27fabb0
+EBUILD singularity-3.8.4.ebuild 1909 BLAKE2B 345f4286e94ab41b16beb32498f84b10e9c53b70a94dd59f3be44f0762785ddb514dcef6c688541a11d02fa36b01426029a3f6802f175fbb34e6e8cafa789a52 SHA512 21c185762d6aa45e4e15301b3c3bfff41fa4d5ec46f79e4f8647d9a79debfc6f6852603a7f64b1ef547dd927c4e8c72646a552a21483ac88e8a595c6f27fabb0
MISC metadata.xml 452 BLAKE2B 5b210e6e78898e3bd858298ec713422552846c5b89c28af42df7d3ccba7935abcacb0a0c190580016c24b311e9dab2804e46337a0ad9cc1de438ae100f1fc512 SHA512 17b00ea10ebd8b196a7c7f5e42d9ea693ae8dfa2749b65612f07b11ba88552223e6c1a5bfad774fdbf97fb399ac71a8dd0637c4f74344cf22cba76dfce4598bf
diff --git a/sys-cluster/singularity/singularity-3.8.4.ebuild b/sys-cluster/singularity/singularity-3.8.4.ebuild
new file mode 100644
index 000000000000..1875b1b03824
--- /dev/null
+++ b/sys-cluster/singularity/singularity-3.8.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="https://sylabs.io"
+SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network +suid"
+
+# Do not complain about CFLAGS etc. since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+COMMON="sys-libs/libseccomp"
+BDEPEND="virtual/pkgconfig"
+DEPEND="${COMMON}
+ >=dev-lang/go-1.13.0
+ app-crypt/gpgme
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup"
+RDEPEND="${COMMON}
+ sys-fs/squashfs-tools"
+
+CONFIG_CHECK="~SQUASHFS"
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --runstatedir=/run \
+ --localstatedir=/var \
+ $(usex network "" "--without-network") \
+ $(usex suid "" "--without-suid")
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -C builddir install
+ keepdir /var/singularity/mnt/session
+
+ # As of version 3.5.3 this seems to be very much broken, affecting
+ # commands which have got nothing to do with singularity (example:
+ # completion on 'udisks mount -b /dev/' rejects all files from that
+ # directory other than 'autofs'). Moreover, this should go into
+ # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
+ # Hopefully temporary, which is why we delete this at install time
+ # instead of patching build scripts not to generate bash-completion
+ # data in the first place.
+ rm -rf "${ED}"/etc/bash_completion.d || die
+
+ dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
+ if use examples; then
+ dodoc -r examples
+ fi
+}