summaryrefslogtreecommitdiff
path: root/sys-cluster/singularity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /sys-cluster/singularity
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest4
-rw-r--r--sys-cluster/singularity/metadata.xml6
-rw-r--r--sys-cluster/singularity/singularity-3.5.3-r1.ebuild69
3 files changed, 77 insertions, 2 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index c8691976971b..a4852649b675 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,3 +1,5 @@
DIST singularity-2.6.1.tar.gz 835029 BLAKE2B 4a581e1bc5df9d664d68f17e275f01081c850aa53f8a9bfcceaf5eb2b8f16e3a018f88669674c7427c60ab00ec0f21b4ec5e6ecaab261c16f70a998cb54ff855 SHA512 063327c67dae2629d1decebc060c474a72e6741f6dc9b6373734e429ccf11d53ee55c1578c28e74e8f8bcda87f3e0b735a3a0e982c9ea894f03a31eaaadf617c
+DIST singularity-3.5.3.tar.gz 7885009 BLAKE2B 8afa2223906e7abf5f3d796efe7cf243dd9d91e61c8ca143a755ad772618ed01d20b7f4a030e82767cf9bf2a7431848d8344e30bde38f413ecd2eef0a9bab53e SHA512 b8bb44539e78eaf74c1b97e5bae8fae1f390412456d76b573fffe2a90240b182db1aec60aee80715547c3edfbaa0607506e2727a575bc951223f9a7c3be0a97e
EBUILD singularity-2.6.1.ebuild 887 BLAKE2B 19268b434a825c6d03c7a53741553aefd9d14796abfbda8e954436829456026003a705c86df8bb83b6f802289b54cde226000cbe0c0768d43816484f6fa17873 SHA512 ade0b12d26dc2991824fa6b90fc91adcb3a1d6d798f6484b5f124197493ecc9d88bfeeebb1493182c684dab234c2c8b9cc3e5a9c4ffb0d1fbf413853d3b5e14a
-MISC metadata.xml 336 BLAKE2B 8da1deed407d4f546b3765bd240bda546a0dd7756d70468490547f38f4e1ca7ac6be41d74c881359cefb28c7ff87eb94012f15d0411be9843603b7cdd35a3999 SHA512 02684993daeb7128cb6e4a4561144b90eee37318e8581821a870e072e39f04f61723a09c430f9fd92e38804de901421b3a1f3cab12ccf37d2d403eb688d5170f
+EBUILD singularity-3.5.3-r1.ebuild 1808 BLAKE2B 423f260e996e91b4666e03c27ed038af1b587dfb787054a62d7c1903b0b514acdaba6b7feec7c1230568881191596f98a6ab7653e06ed7f6c30e8c70654e7aa0 SHA512 b2532538e7102ef908cb61b1aa8b4271da412ed80e5a2ed50d83a5e1c25a7f7a4908fd94581231eca8224b5e22321b9895d66ed34b4a620e9d4bbd8afb991915
+MISC metadata.xml 451 BLAKE2B d68571ca2f95ec8c3212a64b8fd77056ee933ddb4c4789899bacb590e6c52d4fee2b2a53cb7dbd8a109c616ae5464d97b37fc4dbb094b68cdf4abbba8def7c70 SHA512 88105dac9813ba9f7126adae945898ad15e79b7abcea6eda8b6231de72bc48392fd8029b9d6bcb2ec9b0f4dfb0b2d14d90096ac0080f2da200b9802a77ccf38a
diff --git a/sys-cluster/singularity/metadata.xml b/sys-cluster/singularity/metadata.xml
index f47500258195..e7f7edb94ed6 100644
--- a/sys-cluster/singularity/metadata.xml
+++ b/sys-cluster/singularity/metadata.xml
@@ -5,7 +5,11 @@
<email>jlec@gentoo.org</email>
<name>Justin Lecher</name>
</maintainer>
+ <use>
+ <flag name="network">Install network plug-ins</flag>
+ <flag name="suid">Install SUID helper binary</flag>
+ </use>
<upstream>
- <remote-id type="github">singularityware/singularity</remote-id>
+ <remote-id type="github">sylabs/singularity</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sys-cluster/singularity/singularity-3.5.3-r1.ebuild b/sys-cluster/singularity/singularity-3.5.3-r1.ebuild
new file mode 100644
index 000000000000..16834ae083a3
--- /dev/null
+++ b/sys-cluster/singularity/singularity-3.5.3-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="https://sylabs.io"
+SRC_URI="https://github.com/sylabs/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network +suid"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+COMMON="sys-libs/libseccomp"
+BDEPEND="virtual/pkgconfig"
+DEPEND="${COMMON}
+ >=dev-lang/go-1.13.0
+ app-crypt/gpgme
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup"
+RDEPEND="${COMMON}
+ sys-fs/squashfs-tools"
+
+CONFIG_CHECK="~SQUASHFS"
+
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ local myconfargs=(
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --runstatedir=/run \
+ --localstatedir=/var \
+ $(usex network "" "--without-network") \
+ $(usex suid "" "--without-suid")
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -C builddir install
+ keepdir /var/singularity/mnt/session
+
+ # As of version 3.5.3 this seems to be very much broken, affecting
+ # commands which have got nothing to do with singularity (example:
+ # completion on 'udisks mount -b /dev/' rejects all files from that
+ # directory other than 'autofs'). Moreover, this should go into
+ # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
+ # Hopefully temporary, which is why we delete this at install time
+ # instead of patching build scripts not to generate bash-completion
+ # data in the first place.
+ rm -rf "${ED}"/etc/bash_completion.d || die
+
+ dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
+ if use examples; then
+ dodoc -r examples
+ fi
+}