summaryrefslogtreecommitdiff
path: root/sys-cluster/singularity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /sys-cluster/singularity
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest2
-rw-r--r--sys-cluster/singularity/singularity-3.8.5.ebuild71
2 files changed, 0 insertions, 73 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index aa58026a2965..8c5c75a07cde 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,5 +1,3 @@
-DIST singularity-3.8.5.tar.gz 7898598 BLAKE2B 3cf76734d6208340d8562f3d3d67f95c507bad3fad6797d82aed39aa39288385ca02d62854f3dddcfc1a1e3056e7485f27e6081c152b853c682ca8e3a587cf3a SHA512 857761f47528a841a3cf11b49583ab7e8a2d137703e1826ff194011abba3334ed06859219e0c457f352304e7b18f1c493a8b337cc5df67981eb428c567d0ac5f
DIST singularity-3.8.7.tar.gz 8185470 BLAKE2B afa1b0b5b3096e0f3634ce7b61bc19a9d5435a213e241220d2fb19cdb65e93b05e4d8a27db89eeaed6af6b4ab5e09a8914d21a3ff0be88a7c6c8d6245dce9e30 SHA512 5649264c15414b90bab47d1958ec61681fa0b9e37ee445a5059f78f3d822aa27f5b9c5c4f4010d053ec9d03e0215c67e2de8e315f74de7d3cd16b8399f40ee59
-EBUILD singularity-3.8.5.ebuild 1981 BLAKE2B 142b49af9107f82191cdd9f6d30aa5fc91b80b99f7c02a143d4a3034383c3e8267440ffd63e798d858b0d9fc492119af69a92c31a526fd5abe68caa90374c527 SHA512 bbd5b496bced3218e409e056d461bb391fb241c91b4e9d4e428a52ee532cec84e60c26125d263950282ea2214e582765032d6b68f94dbebbde3033eeead65b5e
EBUILD singularity-3.8.7.ebuild 2011 BLAKE2B b8f0f131d647484544c3d7ff950ea4a92ec028fc8a8480e55998d8be88a7d68d4efb1e72b32c3c663e7dd84ab38decb35a6957b0147817433c5b4014fe61b642 SHA512 c38b55f346d746796b7fc434dbd4387fa35fc15e569c3a86889b1e604cfb433b6ebf9345ea40d094edc73742e3087b281fdb5e8a90deb36569cd5073b71617e7
MISC metadata.xml 456 BLAKE2B 2fe2e6f15b6998b662296caafe976db4472e553ca93d2de2c3703bbbec545f2ca28c04cd5b794563b79726f34341d57c11e1b46481ccfb3d0d499a68c7ba46d8 SHA512 d3162fb561bee3e34423fa42256cb6247b1a9e398d8c9675939991e88fd3ba02baa5dfab21045dfcab30489cb0509e42637bcbd62a8483b08025904a6c2a8dbd
diff --git a/sys-cluster/singularity/singularity-3.8.5.ebuild b/sys-cluster/singularity/singularity-3.8.5.ebuild
deleted file mode 100644
index 0ecdfaee462b..000000000000
--- a/sys-cluster/singularity/singularity-3.8.5.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-info toolchain-funcs
-
-DESCRIPTION="Application containers for Linux"
-HOMEPAGE="https://github.com/apptainer/singularity"
-SRC_URI="https://github.com/apptainer/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 ~riscv x86 ~amd64-linux ~x86-linux"
-IUSE="examples +network +suid"
-
-# Do not complain about CFLAGS etc. since go projects do not use them.
-QA_FLAGS_IGNORED='.*'
-
-COMMON="sys-libs/libseccomp"
-BDEPEND="virtual/pkgconfig"
-DEPEND="${COMMON}
- >=dev-lang/go-1.16.0
- app-crypt/gpgme
- dev-libs/openssl
- sys-apps/util-linux
- sys-fs/cryptsetup"
-RDEPEND="${COMMON}
- sys-fs/squashfs-tools"
-
-CONFIG_CHECK="~SQUASHFS"
-
-src_configure() {
- local myconfargs=(
- -c "$(tc-getBUILD_CC)" \
- -x "$(tc-getBUILD_CXX)" \
- -C "$(tc-getCC)" \
- -X "$(tc-getCXX)" \
- --prefix="${EPREFIX}"/usr \
- --sysconfdir="${EPREFIX}"/etc \
- --runstatedir="${EPREFIX}"/run \
- --localstatedir="${EPREFIX}"/var \
- $(usex network "" "--without-network") \
- $(usex suid "" "--without-suid")
- )
- ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
-}
-
-src_compile() {
- emake -C builddir
-}
-
-src_install() {
- emake DESTDIR="${D}" -C builddir install
- keepdir /var/singularity/mnt/session
-
- # As of version 3.5.3 this seems to be very much broken, affecting
- # commands which have got nothing to do with singularity (example:
- # completion on 'udisks mount -b /dev/' rejects all files from that
- # directory other than 'autofs'). Moreover, this should go into
- # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
- # Hopefully temporary, which is why we delete this at install time
- # instead of patching build scripts not to generate bash-completion
- # data in the first place.
- rm -rf "${ED}"/etc/bash_completion.d || die
-
- dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
- if use examples; then
- dodoc -r examples
- fi
-}