summaryrefslogtreecommitdiff
path: root/sys-cluster/resource-agents/resource-agents-4.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-18 06:58:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-18 06:58:04 +0000
commit070c77515d1406e762e9e344856546f0a15765b6 (patch)
treee9c59800869ff27454b82c6afa378a4fee0ef935 /sys-cluster/resource-agents/resource-agents-4.11.0.ebuild
parent6330245077f9f298a785e17756a8f59a843361a5 (diff)
gentoo auto-resync : 18:11:2022 - 06:58:04
Diffstat (limited to 'sys-cluster/resource-agents/resource-agents-4.11.0.ebuild')
-rw-r--r--sys-cluster/resource-agents/resource-agents-4.11.0.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sys-cluster/resource-agents/resource-agents-4.11.0.ebuild b/sys-cluster/resource-agents/resource-agents-4.11.0.ebuild
new file mode 100644
index 000000000000..d5c32f56840b
--- /dev/null
+++ b/sys-cluster/resource-agents/resource-agents-4.11.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${P/resource-}"
+inherit autotools
+
+DESCRIPTION="Resources pack for Heartbeat / Pacemaker"
+HOMEPAGE="http://www.linux-ha.org/wiki/Resource_Agents"
+SRC_URI="https://github.com/ClusterLabs/resource-agents/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc libnet rgmanager systemd"
+
+RDEPEND="
+ sys-apps/iproute2
+ >=sys-cluster/cluster-glue-1.0.12-r1
+ libnet? ( net-libs/libnet:1.1 )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/4.6.1-configure.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # --with-ocf-root needs to be /usr/lib, see bug #720420
+ econf \
+ --disable-fatal-warnings \
+ --localstatedir=/var \
+ --with-ocf-root=/usr/lib/ocf \
+ --with-rsctmpdir=/run/resource-agents \
+ $(use_enable doc) \
+ $(use_enable libnet)
+}
+
+src_install() {
+ default
+
+ rm -rf "${ED}/usr/lib/ocf/resource.d/redhat" || die
+ rm -rf "${ED}"/etc/init.d/ || die
+ rm -rf "${ED}"{,/var}/run || die
+
+ use rgmanager || rm -rf "${ED}"/usr/share/cluster/ "${ED}"/var/
+}
+
+pkg_postinst() {
+ elog "To use Resource Agents installed in ${EROOT}/usr/lib/ocf/resource.d"
+ elog "you have to emerge required runtime dependencies manually."
+ elog ""
+ elog "Description and dependencies of all Agents can be found on"
+ elog "http://www.linux-ha.org/wiki/Resource_Agents"
+ elog "or in the documentation of this package."
+}