summaryrefslogtreecommitdiff
path: root/sys-cluster/ploop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sys-cluster/ploop
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sys-cluster/ploop')
-rw-r--r--sys-cluster/ploop/Manifest3
-rw-r--r--sys-cluster/ploop/files/disable_create_run_dir.patch4
-rw-r--r--sys-cluster/ploop/ploop-1.14.1-r1.ebuild63
3 files changed, 67 insertions, 3 deletions
diff --git a/sys-cluster/ploop/Manifest b/sys-cluster/ploop/Manifest
index fee0ab31cfc3..de48b2170662 100644
--- a/sys-cluster/ploop/Manifest
+++ b/sys-cluster/ploop/Manifest
@@ -1,4 +1,5 @@
-AUX disable_create_run_dir.patch 632 BLAKE2B 9b4c817cbf77de4b33063f42d832f729542da24cbd9c8c495f5383562e1228322e3c41321f4c2f09b9745dfc56420c74cc94dc380a7780d01dbd71a1f5a04d99 SHA512 4ef81f24a21f200881f2ff94ba9d39f1b097362eb371623a62dc7d66c7e174e3e7a465be85856c7c5ca8a01d8fe725bd9d713f871af8cec3c25bc94811d7c415
+AUX disable_create_run_dir.patch 560 BLAKE2B 08be833a3afd51560f91337e750027fc13163244e3709399a7824a0afe432c86820cb97b703276e2a64968aeba2c63c44a4944fee080a4e4414928f72bc3da31 SHA512 69f2fe1214bc9fa3cae47bf55af94df83b21c1c19f04a60ddae7d7e261ef59a90ab1ed6dbed63271db2c97ae0b476c3bc69bbde656d85af3ef2c16f4ebb0a7e4
DIST ploop-1.14.1.tar.bz2 123962 BLAKE2B d4f4f102d2ec0714d79901bd3193f85514e232dc18ffcab254becb954cf794f3598fe7b0f65d0bbb85766bff5ded9d816900b40b81cb6046c31d8b6459c67618 SHA512 7a235865f071de6e2762923d6591c8c6ee00d0d05ec80c6a2a1332f5b6881ccf827f7ddc40dfe1d663b8abf492a188a23f7d28a43dd553d6e37c8091cb3bc484
+EBUILD ploop-1.14.1-r1.ebuild 1411 BLAKE2B d28e1988e5b0bd869b2fcd03e1786b92507aec984a5521454d8b6ccdf839982cb6f3c3f605efae1557db4a1ea493219be1b9de9408dd0a4f3322d7a5cdb708e4 SHA512 6c530ddcae0609b0b7e2943fd03461de73f9baaf53f7adf14132d2dc4b4abdad827909243058b69aca390c9d44a1e5b6db949e09cd891398c71a9086e1a8910d
EBUILD ploop-1.14.1.ebuild 1465 BLAKE2B ca02d9dcb3a5b7fbf509ba511f2c707866d157451d9a29078bce451447281b4545d0eac65b317aeeb04afd78fcee34cefc9df11dee53df28469321eca57cce47 SHA512 ea81975710843518d76d4e60aad9fc4927b252dbb69173209c92678385f1ed5bbb7ea55ce2ba4ab4b543b4769540c0c8fea85a1650968c239e4c046d08c53464
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/sys-cluster/ploop/files/disable_create_run_dir.patch b/sys-cluster/ploop/files/disable_create_run_dir.patch
index 726094903b51..597a6c1d160d 100644
--- a/sys-cluster/ploop/files/disable_create_run_dir.patch
+++ b/sys-cluster/ploop/files/disable_create_run_dir.patch
@@ -1,5 +1,5 @@
---- lib/Makefile.old 2015-10-10 15:49:25.377235002 +0300
-+++ lib/Makefile 2015-10-10 15:49:50.021464544 +0300
+--- a/lib/Makefile
++++ b/lib/Makefile
@@ -76,17 +76,13 @@
.depend: $(filter-out $(GENERATED),$(SOURCES))
-include .depend
diff --git a/sys-cluster/ploop/ploop-1.14.1-r1.ebuild b/sys-cluster/ploop/ploop-1.14.1-r1.ebuild
new file mode 100644
index 000000000000..5133adf338ac
--- /dev/null
+++ b/sys-cluster/ploop/ploop-1.14.1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit tmpfiles toolchain-funcs
+
+DESCRIPTION="openvz tool and a library to control ploop block devices"
+HOMEPAGE="https://wiki.openvz.org/Download/ploop"
+SRC_URI="https://download.openvz.org/utils/ploop/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/libxml2"
+RDEPEND="${DEPEND}
+ sys-block/parted
+ sys-fs/e2fsprogs
+ sys-process/lsof
+ sys-apps/findutils"
+
+PATCHES=(
+ "${FILESDIR}"/disable_create_run_dir.patch
+)
+
+DOCS=( tools/README )
+
+src_prepare() {
+ default
+
+ # Respect CFLAGS and CC, do not add debug by default
+ sed -i \
+ -e 's|CFLAGS =|CFLAGS +=|' \
+ -e '/CFLAGS/s/-g -O0 //' \
+ -e '/CFLAGS/s/-O2//' \
+ -e 's|CC=|CC?=|' \
+ -e 's/-Werror//' \
+ -e '/DEBUG=yes/d' \
+ -e '/LOCKDIR/s/var/run/' \
+ Makefile.inc || die 'sed on Makefile.inc failed'
+ # Avoid striping of binaries
+ sed -e '/INSTALL/{s: -s::}' -i tools/Makefile || die 'sed on tools/Makefile failed'
+
+ # respect AR and RANLIB, bug #452092
+ tc-export AR RANLIB
+ sed -i -e 's/ranlib/$(RANLIB)/' lib/Makefile || die 'sed on lib/Makefile failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 $(usex debug 'DEBUG' '' '=yes' '')
+}
+
+src_install() {
+ default
+ rm "${ED}"/usr/$(get_libdir)/*.a || die
+}
+
+pkg_postinst() {
+ tmpfiles_process ploop.conf
+}