summaryrefslogtreecommitdiff
path: root/sys-cluster/pconsole/pconsole-1.0-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
commitf625b9919a60a30f1bd860f7d1b2eac183ced593 (patch)
tree7543f00925ff7277e31881de0a87801681f6f92f /sys-cluster/pconsole/pconsole-1.0-r4.ebuild
parente3872864be25f7421015bef2732fa57c0c9fb726 (diff)
gentoo resync : 08.08.2018
Diffstat (limited to 'sys-cluster/pconsole/pconsole-1.0-r4.ebuild')
-rw-r--r--sys-cluster/pconsole/pconsole-1.0-r4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-cluster/pconsole/pconsole-1.0-r4.ebuild b/sys-cluster/pconsole/pconsole-1.0-r4.ebuild
new file mode 100644
index 000000000000..1d6ce3d826e4
--- /dev/null
+++ b/sys-cluster/pconsole/pconsole-1.0-r4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for managing multiple xterms simultaneously"
+HOMEPAGE="https://github.com/walterdejong/pconsole"
+SRC_URI="http://www.xs4all.nl/~walterj/pconsole/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-exit-warn.patch )
+
+src_compile() {
+ emake LFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin pconsole
+ fperms 4110 /usr/bin/pconsole
+ dodoc ChangeLog README.pconsole public_html/pconsole.html
+}
+
+pkg_postinst() {
+ ewarn "Warning:"
+ ewarn "pconsole installed with suid root!"
+}