summaryrefslogtreecommitdiff
path: root/sys-cluster/pconsole/pconsole-1.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/pconsole/pconsole-1.0-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/pconsole/pconsole-1.0-r3.ebuild')
-rw-r--r--sys-cluster/pconsole/pconsole-1.0-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-cluster/pconsole/pconsole-1.0-r3.ebuild b/sys-cluster/pconsole/pconsole-1.0-r3.ebuild
new file mode 100644
index 000000000000..e071f8b28ba4
--- /dev/null
+++ b/sys-cluster/pconsole/pconsole-1.0-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool for managing multiple xterms simultaneously"
+HOMEPAGE="http://www.heiho.net/pconsole/"
+SRC_URI="http://www.xs4all.nl/~walterj/pconsole/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/ssh"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-exit-warn.patch
+}
+
+src_compile() {
+ emake LFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin pconsole || die
+ fperms 4110 /usr/bin/pconsole || die
+ dodoc ChangeLog README.pconsole || die
+ dohtml public_html/pconsole.html || die
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Warning:"
+ ewarn "pconsole installed with suid root!"
+ echo
+}