summaryrefslogtreecommitdiff
path: root/sys-cluster/openais/openais-1.1.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
commit7b9f15840068dfaeea5684f8a1af1fe460dfa14c (patch)
tree112eea4497761c0227537330b58f9c7e0af3f9d8 /sys-cluster/openais/openais-1.1.4-r1.ebuild
parent0bff53119f08d677db6c1a991bd30741682a8a08 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'sys-cluster/openais/openais-1.1.4-r1.ebuild')
-rw-r--r--sys-cluster/openais/openais-1.1.4-r1.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/sys-cluster/openais/openais-1.1.4-r1.ebuild b/sys-cluster/openais/openais-1.1.4-r1.ebuild
index bf42581c57c3..e052e5a0af63 100644
--- a/sys-cluster/openais/openais-1.1.4-r1.ebuild
+++ b/sys-cluster/openais/openais-1.1.4-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit autotools base
+inherit autotools
DESCRIPTION="Open Application Interface Specification cluster framework"
HOMEPAGE="http://www.openais.org/"
@@ -21,6 +21,8 @@ DEPEND="${RDEPEND}
DOCS=( "${S}/AUTHORS" "${S}/README.amf" )
src_prepare() {
+ default
+
# respect CFLAGS
sed -i -e "s/\$OPT_CFLAGS \$GDB_FLAGS//" configure.ac || die
# respect LDFLAGS
@@ -28,18 +30,21 @@ src_prepare() {
services/Makefile.am || die
# don't install docs
sed -i -e "/^dist_doc/d" Makefile.am || die
+
eautoreconf
}
src_configure() {
econf \
- --disable-dependency-tracking \
- --docdir=/usr/share/doc/${PF} \
- --localstatedir=/var
+ --localstatedir="${EPREFIX}"/var
}
src_install() {
- base_src_install
+ default
+
rm -rf "${D}"/etc/init.d/openais || die
- use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.a || die
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die "Pruning failed"
+ fi
}