summaryrefslogtreecommitdiff
path: root/sys-cluster/ocfs/ocfs-1.0.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/ocfs/ocfs-1.0.14.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/ocfs/ocfs-1.0.14.ebuild')
-rw-r--r--sys-cluster/ocfs/ocfs-1.0.14.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-cluster/ocfs/ocfs-1.0.14.ebuild b/sys-cluster/ocfs/ocfs-1.0.14.ebuild
new file mode 100644
index 000000000000..ecbeed23ad84
--- /dev/null
+++ b/sys-cluster/ocfs/ocfs-1.0.14.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit linux-mod
+
+DESCRIPTION="The Oracle Cluster Filesystem"
+SRC_URI="http://oss.oracle.com/projects/ocfs/dist/files/source/${P}.tar.gz"
+HOMEPAGE="http://oss.oracle.com/projects/ocfs"
+LICENSE="GPL-2"
+
+DEPEND="virtual/linux-sources"
+
+IUSE="aio"
+SLOT="0"
+KEYWORDS="~x86"
+
+pkg_setup() {
+ if kernel_is -ge 2 6; then
+ die "${P} supports only 2.4 kernels"
+ fi
+}
+
+src_compile() {
+ set_arch_to_kernel
+ local myconf
+ use aio && myconf="--enable-aio=yes" || myconf="--enable-aio=no"
+
+ econf \
+ --with-kernel=${KV_DIR} \
+ ${myconf} \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ einstall DESTDIR=${D} || die "Failed to install"
+
+ dodir /etc/ocfs
+ insinto /etc/ocfs
+ doins ocfs2/ocfs.conf
+
+ dodoc README docs/ocfs_doc.zip || die
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo ""
+ einfo "Please remember to re-emerge ${PN} when you upgrade your kernel!"
+ einfo ""
+ einfo "Please edit the configuration file /etc/ocfs/ocfs.conf"
+ einfo ""
+}