summaryrefslogtreecommitdiff
path: root/sys-cluster/maui/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/maui/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/maui/files')
-rw-r--r--sys-cluster/maui/files/3.2.6_p21-autoconf-2.60-compat.patch11
-rw-r--r--sys-cluster/maui/files/maui-3.2.6_p21-pbs-nodefile.patch23
-rw-r--r--sys-cluster/maui/files/maui-3.3.1-torque_4.patch14
-rw-r--r--sys-cluster/maui/files/maui.initd23
4 files changed, 71 insertions, 0 deletions
diff --git a/sys-cluster/maui/files/3.2.6_p21-autoconf-2.60-compat.patch b/sys-cluster/maui/files/3.2.6_p21-autoconf-2.60-compat.patch
new file mode 100644
index 000000000000..9b77a27f88df
--- /dev/null
+++ b/sys-cluster/maui/files/3.2.6_p21-autoconf-2.60-compat.patch
@@ -0,0 +1,11 @@
+--- maui-3.2.6p21.orig/Makefile.in 2006-05-23 15:20:49.000000000 -0700
++++ maui-3.2.6p21/Makefile.in 2006-09-25 20:42:24.000000000 -0700
+@@ -18,7 +18,7 @@
+ # ============================
+ # Resource Manager section
+ # ============================
+-@ll_definitions@@sdr_definitions@@pbs_definitions@@sge_definitions@@lsf_definitions@@mx_definitions@@pcre_definitions@
++@pbs_definitions@
+
+ # ============================
+ # Master Makefile for @PACKAGE_NAME@-@PACKAGE_VERSION@
diff --git a/sys-cluster/maui/files/maui-3.2.6_p21-pbs-nodefile.patch b/sys-cluster/maui/files/maui-3.2.6_p21-pbs-nodefile.patch
new file mode 100644
index 000000000000..90bf80ca661a
--- /dev/null
+++ b/sys-cluster/maui/files/maui-3.2.6_p21-pbs-nodefile.patch
@@ -0,0 +1,23 @@
+--- maui-3.2.6p21/src/moab/MPBSI.c.orig 2010-03-16 12:54:09.000000000 +0100
++++ maui-3.2.6p21/src/moab/MPBSI.c 2010-03-16 12:57:07.000000000 +0100
+@@ -6406,6 +6406,7 @@
+ int tindex;
+
+ char tmpHostName[MAX_MLINE];
++ char tmpTaskList[MAX_MLINE+10];
+
+ mnode_t *N;
+
+@@ -6458,10 +6459,10 @@
+ }
+ else
+ {
+- sprintf(TSBuf,"%s%s:ppn=%d",
+- TSBuf,
++ snprintf (tmpTaskList,MAX_MLINE+10,"%s:ppn=%d",
+ tmpHostName,
+ NL[tindex].TC);
++ MUStrCat(TSBuf,tmpTaskList,BufSize);
+ }
+ } /* END for (tindex) */
+
diff --git a/sys-cluster/maui/files/maui-3.3.1-torque_4.patch b/sys-cluster/maui/files/maui-3.3.1-torque_4.patch
new file mode 100644
index 000000000000..1e0631555736
--- /dev/null
+++ b/sys-cluster/maui/files/maui-3.3.1-torque_4.patch
@@ -0,0 +1,14 @@
+diff -ur maui-3.3.1.orig/src/moab/MPBSI.c maui-3.3.1/src/moab/MPBSI.c
+--- maui-3.3.1.orig/src/moab/MPBSI.c 2013-07-31 09:36:31.831849229 -0700
++++ maui-3.3.1/src/moab/MPBSI.c 2013-07-31 09:37:12.951107957 -0700
+@@ -174,8 +174,8 @@
+
+ extern int pbs_errno;
+
+-extern int get_svrport(const char *,char *,int);
+-extern int openrm(char *,int);
++extern unsigned int get_svrport(char *,char *,unsigned int);
++extern int openrm(char *,unsigned int);
+ extern int addreq(int,char *);
+ extern int closerm(int);
+ extern int pbs_stagein(int,char *,char *,char *);
diff --git a/sys-cluster/maui/files/maui.initd b/sys-cluster/maui/files/maui.initd
new file mode 100644
index 000000000000..df4f64474f1f
--- /dev/null
+++ b/sys-cluster/maui/files/maui.initd
@@ -0,0 +1,23 @@
+#!/sbin/openrc-run
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+ after pbs_server slurmctld
+ before pbs_mom slurmd
+ after logger
+}
+
+start() {
+ ebegin "Starting Maui scheduler"
+ start-stop-daemon --start --exec /usr/sbin/maui
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping Maui scheduler"
+ start-stop-daemon --stop -p /var/spool/maui/maui.pid
+ eend ${?}
+}
+# vim:ts=4