summaryrefslogtreecommitdiff
path: root/sys-cluster/legion/legion-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /sys-cluster/legion/legion-9999.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'sys-cluster/legion/legion-9999.ebuild')
-rw-r--r--sys-cluster/legion/legion-9999.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/sys-cluster/legion/legion-9999.ebuild b/sys-cluster/legion/legion-9999.ebuild
index bc5ad7cee85d..55c79a8cda25 100644
--- a/sys-cluster/legion/legion-9999.ebuild
+++ b/sys-cluster/legion/legion-9999.ebuild
@@ -1,41 +1,42 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils
+inherit cmake
DESCRIPTION="A data-centric parallel programming system"
HOMEPAGE="https://legion.stanford.edu/"
-if [[ ${PV} = 9999 ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
else
SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${P}
+
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-${P}"
fi
LICENSE="BSD"
SLOT="0"
-IUSE="gasnet +hwloc test"
+IUSE="examples gasnet hwloc test"
RESTRICT="!test? ( test )"
-DEPEND="
+# See bug #821424 for examples/mpi
+DEPEND="examples? ( virtual/mpi[cxx] )
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( <sys-apps/hwloc-2:= )
- "
+ hwloc? ( <sys-apps/hwloc-2:= )"
RDEPEND="${DEPEND}"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DLegion_USE_HWLOC=$(usex hwloc)
-DLegion_USE_GASNet=$(usex gasnet)
-DLegion_ENABLE_TESTING=$(usex test)
- -DBUILD_SHARED_LIBS=ON
- -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_EXAMPLES=$(usex examples)
-DLegion_BUILD_TESTS=ON
-DLegion_BUILD_TUTORIAL=ON
)
- cmake-utils_src_configure
+
+ cmake_src_configure
}