summaryrefslogtreecommitdiff
path: root/sys-cluster/legion/legion-16.08.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/legion/legion-16.08.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/legion/legion-16.08.0-r1.ebuild')
-rw-r--r--sys-cluster/legion/legion-16.08.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-cluster/legion/legion-16.08.0-r1.ebuild b/sys-cluster/legion/legion-16.08.0-r1.ebuild
new file mode 100644
index 000000000000..e90f7d02ed71
--- /dev/null
+++ b/sys-cluster/legion/legion-16.08.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="http://legion.stanford.edu/"
+SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gasnet +hwloc"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( sys-apps/hwloc )
+ "
+
+S="${WORKDIR}/${PN}-${P}"
+
+#https://github.com/StanfordLegion/legion/pull/166
+#https://github.com/StanfordLegion/legion/pull/167
+PATCHES=( "${FILESDIR}/${P}-hwloc.patch" "${FILESDIR}/${P}-multilib.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DBUILD_SHARED_LIBS=ON
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}