summaryrefslogtreecommitdiff
path: root/sys-cluster/kubelogin/kubelogin-1.27.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
commit115dcc7054f5934a2c8e26fd8a8eed5f3e29e9ce (patch)
treec31afe35699960753f76770d6b0b4ea48af9f686 /sys-cluster/kubelogin/kubelogin-1.27.0.ebuild
parente292b671b113c2cc012beddad93a3df4f9410698 (diff)
gentoo auto-resync : 28:03:2023 - 09:49:10
Diffstat (limited to 'sys-cluster/kubelogin/kubelogin-1.27.0.ebuild')
-rw-r--r--sys-cluster/kubelogin/kubelogin-1.27.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-cluster/kubelogin/kubelogin-1.27.0.ebuild b/sys-cluster/kubelogin/kubelogin-1.27.0.ebuild
new file mode 100644
index 000000000000..5d38e4717f8f
--- /dev/null
+++ b/sys-cluster/kubelogin/kubelogin-1.27.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="kubectl plugin for Kubernetes OpenID Connect authentication"
+HOMEPAGE="https://github.com/int128/kubelogin"
+SRC_URI="https://github.com/int128/kubelogin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~concord/distfiles/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -ldflags="-s -w" -o ./bin/${PN} .
+}
+
+src_install() {
+ newbin bin/${PN} "kubectl-oidc_login"
+ bin/${PN} completion bash > ${PN}.bash || die
+ bin/${PN} completion zsh > ${PN}.zsh || die
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+}