summaryrefslogtreecommitdiff
path: root/sys-cluster/kubectl/kubectl-1.26.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-25 21:55:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-25 21:55:22 +0100
commit2a27c2168109b412410436b9cd6b71dbfe31f6ef (patch)
tree22d3cb59b0c68f1766670f2d010aa2d3b3b6ea22 /sys-cluster/kubectl/kubectl-1.26.8.ebuild
parentd0bb3151c569ab6e40c84c177f43bff3c7ce4780 (diff)
gentoo auto-resync : 25:08:2023 - 21:55:22
Diffstat (limited to 'sys-cluster/kubectl/kubectl-1.26.8.ebuild')
-rw-r--r--sys-cluster/kubectl/kubectl-1.26.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-cluster/kubectl/kubectl-1.26.8.ebuild b/sys-cluster/kubectl/kubectl-1.26.8.ebuild
new file mode 100644
index 000000000000..0a6d3b7c65b8
--- /dev/null
+++ b/sys-cluster/kubectl/kubectl-1.26.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="CLI to run commands against Kubernetes clusters"
+HOMEPAGE="https://kubernetes.io"
+SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="hardened"
+
+BDEPEND=">=dev-lang/go-1.19"
+
+RESTRICT+=" test"
+S="${WORKDIR}/kubernetes-${PV}"
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
+ emake -j1 GOFLAGS="" GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
+}
+
+src_install() {
+ dobin _output/bin/${PN}
+ _output/bin/${PN} completion bash > ${PN}.bash || die
+ _output/bin/${PN} completion zsh > ${PN}.zsh || die
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+}