summaryrefslogtreecommitdiff
path: root/sys-cluster/kubectl/kubectl-1.18.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-cluster/kubectl/kubectl-1.18.10.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-cluster/kubectl/kubectl-1.18.10.ebuild')
-rw-r--r--sys-cluster/kubectl/kubectl-1.18.10.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-cluster/kubectl/kubectl-1.18.10.ebuild b/sys-cluster/kubectl/kubectl-1.18.10.ebuild
new file mode 100644
index 000000000000..9640e72af8ee
--- /dev/null
+++ b/sys-cluster/kubectl/kubectl-1.18.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="CLI to run commands against Kubernetes clusters"
+HOMEPAGE="https://kubernetes.io"
+SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="hardened"
+
+RDEPEND="!sys-cluster/kubernetes"
+BDEPEND="=dev-lang/go-1.14*"
+
+RESTRICT+=" test"
+S="${WORKDIR}/kubernetes-${PV}"
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
+ emake -j1 GOFLAGS="" GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
+}
+
+src_install() {
+ dobin _output/bin/${PN}
+ _output/bin/${PN} completion bash > ${PN}.bash || die
+ _output/bin/${PN} completion zsh > ${PN}.zsh || die
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+}