summaryrefslogtreecommitdiff
path: root/sys-cluster/kube-proxy/kube-proxy-1.28.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-18 00:10:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-18 00:10:02 +0100
commitccaccfe4f1da8c11d9fa110f6e4eb847358769d7 (patch)
treeff02c95ae3d9a1e73e2a182e268161743d81a88b /sys-cluster/kube-proxy/kube-proxy-1.28.11.ebuild
parent74e526c590f52d24a213e25f77858ae0b34ec2c8 (diff)
gentoo auto-resync : 18:06:2024 - 00:10:02
Diffstat (limited to 'sys-cluster/kube-proxy/kube-proxy-1.28.11.ebuild')
-rw-r--r--sys-cluster/kube-proxy/kube-proxy-1.28.11.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-cluster/kube-proxy/kube-proxy-1.28.11.ebuild b/sys-cluster/kube-proxy/kube-proxy-1.28.11.ebuild
new file mode 100644
index 000000000000..7088f613c25c
--- /dev/null
+++ b/sys-cluster/kube-proxy/kube-proxy-1.28.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Kubernetes Proxy service"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="hardened"
+
+RDEPEND="net-firewall/conntrack-tools"
+BDEPEND=">=dev-lang/go-1.21.9"
+
+RESTRICT+=" test"
+S="${WORKDIR}/kubernetes-${PV}"
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
+ emake -j1 GOFLAGS="" GOLDFLAGS="" LDFLAGS="" FORCE_HOST_GO=yes \
+ WHAT=cmd/${PN}
+}
+
+src_install() {
+ dobin _output/bin/${PN}
+ keepdir /var/log/${PN} /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotated ${PN}
+}