summaryrefslogtreecommitdiff
path: root/sys-cluster/kube-proxy/kube-proxy-1.27.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-09 22:33:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-09 22:33:12 +0000
commit6147e25e3b1f6ce82b661605708d0b8292c03f47 (patch)
treeb8c60917145c0a076da1e88dd73edfaad594d5a6 /sys-cluster/kube-proxy/kube-proxy-1.27.5.ebuild
parent3f5a5d10d87cd7f434c3a4207fc0a7ffc25d9123 (diff)
gentoo auto-resync : 09:11:2023 - 22:33:12
Diffstat (limited to 'sys-cluster/kube-proxy/kube-proxy-1.27.5.ebuild')
-rw-r--r--sys-cluster/kube-proxy/kube-proxy-1.27.5.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/sys-cluster/kube-proxy/kube-proxy-1.27.5.ebuild b/sys-cluster/kube-proxy/kube-proxy-1.27.5.ebuild
deleted file mode 100644
index 334b1e38e138..000000000000
--- a/sys-cluster/kube-proxy/kube-proxy-1.27.5.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module
-
-DESCRIPTION="Kubernetes Proxy service"
-HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
-SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64"
-IUSE="hardened"
-
-RDEPEND="net-firewall/conntrack-tools"
-BDEPEND=">=dev-lang/go-1.20"
-
-RESTRICT+=" test"
-S="${WORKDIR}/kubernetes-${PV}"
-
-src_compile() {
- CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
- emake -j1 GOFLAGS="" GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
-}
-
-src_install() {
- dobin _output/bin/${PN}
- keepdir /var/log/${PN} /var/lib/${PN}
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/${PN}.logrotated ${PN}
-}