summaryrefslogtreecommitdiff
path: root/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild')
-rw-r--r--sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild b/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild
new file mode 100644
index 000000000000..52156e121819
--- /dev/null
+++ b/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit linux-info
+
+PATCHLEVEL="11"
+MY_PV="${PV}-${PATCHLEVEL}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="utility to administer the IP virtual server services"
+HOMEPAGE="http://linuxvirtualserver.org"
+LICENSE="GPL-2"
+DEPEND=">=sys-libs/ncurses-5.2"
+
+SRC_URI="http://www.linuxvirtualserver.org/software/kernel-2.4/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~ppc ~ppc64 x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if kernel_is -ge 2 6; then
+ eerror "${P} does not support 2.6 kernels, please try newer versions"
+ die "wrong kernel version"
+ fi
+}
+
+src_compile() {
+ emake || die "error compiling source"
+}
+
+src_install() {
+ into /
+ dosbin ipvsadm ipvsadm-save ipvsadm-restore || die
+
+ doman ipvsadm.8 ipvsadm-save.8 ipvsadm-restore.8
+
+ newinitd "${FILESDIR}"/ipvsadm-init ipvsadm || die
+ keepdir /var/lib/ipvsadm
+
+ dolib.a libipvs/libipvs.a || die
+
+ insinto /usr/include/ipvs
+ newins libipvs/libipvs.h ipvs.h || die
+
+ einfo "You will need a kernel that has ipvs patches to use LVS"
+}