summaryrefslogtreecommitdiff
path: root/sys-cluster/hpx/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-cluster/hpx/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-cluster/hpx/files')
-rw-r--r--sys-cluster/hpx/files/hpx-0.9.8-cmake_dir.patch27
-rw-r--r--sys-cluster/hpx/files/hpx-0.9.8-install-path.patch69
-rw-r--r--sys-cluster/hpx/files/hpx-0.9.8-multilib.patch163
3 files changed, 259 insertions, 0 deletions
diff --git a/sys-cluster/hpx/files/hpx-0.9.8-cmake_dir.patch b/sys-cluster/hpx/files/hpx-0.9.8-cmake_dir.patch
new file mode 100644
index 000000000000..b5c66c284752
--- /dev/null
+++ b/sys-cluster/hpx/files/hpx-0.9.8-cmake_dir.patch
@@ -0,0 +1,27 @@
+From e565c2cce934f2d6fa6e80061c416a2e7df0f311 Mon Sep 17 00:00:00 2001
+From: Christoph Junghans <junghans@lanl.gov>
+Date: Tue, 20 May 2014 11:18:21 -0600
+Subject: [PATCH] make cmake_dir configure-able
+
+---
+ CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8ad79cb..e6f392a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1981,7 +1981,9 @@ endforeach()
+ # Make list unique
+ list(REMOVE_DUPLICATES external_definitions)
+
+-set(cmake_dir cmake-${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION})
++if (NOT DEFINED cmake_dir)
++ set(cmake_dir cmake-${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION})
++endif(NOT DEFINED cmake_dir)
+
+ if(MSVC)
+ set(output_dir "${CMAKE_BINARY_DIR}/${CMAKE_BUILD_TYPE}")
+--
+1.8.5.5
+
diff --git a/sys-cluster/hpx/files/hpx-0.9.8-install-path.patch b/sys-cluster/hpx/files/hpx-0.9.8-install-path.patch
new file mode 100644
index 000000000000..f5c867b9b4a2
--- /dev/null
+++ b/sys-cluster/hpx/files/hpx-0.9.8-install-path.patch
@@ -0,0 +1,69 @@
+From 5c04f9c2d47a41f6113f45eeb4dd9f7968f2cd52 Mon Sep 17 00:00:00 2001
+From: Christoph Junghans <junghans@lanl.gov>
+Date: Tue, 20 May 2014 09:27:47 -0600
+Subject: [PATCH] fix make install non-empty DESTDIR
+
+Symlinks were created even when make install was called with a
+non-empty DESTDIR variable. Fixed by creating the symlinks in build
+directory first and then install them using common install.
+DESTDIR installation is needed for binary packages.
+---
+ CMakeLists.txt | 31 +++++++++++++++++++------------
+ 1 file changed, 19 insertions(+), 12 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 00a71c7..8d5df19 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1762,15 +1762,22 @@ if(NOT HPX_NO_INSTALL)
+
+ if(UNIX)
+ file(GLOB scripts "${CMAKE_SOURCE_DIR}/python/scripts/*.py")
++ execute_process(COMMAND "${CMAKE_COMMAND}" -E make_directory
++ "${CMAKE_BINARY_DIR}/python/scripts" )
+ foreach(script ${scripts})
+ get_filename_component(script_name ${script} NAME)
+ get_filename_component(script_name_we ${script} NAME_WE)
+- install(CODE
+- "set(bindir \"${CMAKE_INSTALL_PREFIX}/bin/\")
+- execute_process(
+- COMMAND \"\${CMAKE_COMMAND}\" -E create_symlink
+- \"${script_name}\" \"${script_name_we}\"
+- WORKING_DIRECTORY \"\${bindir}\")")
++
++ #make copy, so that we have intact symlink in CMAKE_BINARY_DIR
++ execute_process(
++ COMMAND "${CMAKE_COMMAND}" -E copy_if_different "${script}" "${script_name}"
++ WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/python/scripts")
++
++ execute_process(
++ COMMAND "${CMAKE_COMMAND}" -E create_symlink "${script_name}" "${script_name_we}"
++ WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/python/scripts")
++
++ install(FILES "${CMAKE_BINARY_DIR}/python/scripts/${script_name_we}" DESTINATION "bin")
+ endforeach()
+ endif()
+
+@@ -1781,13 +1788,13 @@ if(NOT HPX_NO_INSTALL)
+ FILES_MATCHING PATTERN "*.py"
+ PATTERN ".git" EXCLUDE)
+
++ execute_process(COMMAND "${CMAKE_COMMAND}" -E make_directory "${CMAKE_BINARY_DIR}/python" )
++ #make symlink, so that we have intact hpx symlink in CMAKE_BINARY_DIR
++ execute_process(COMMAND "${CMAKE_COMMAND}" -E create_symlink "${CMAKE_SOURCE_DIR}/python/hpx"
++ "hpx-${HPX_VERSION}" WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/python")
+ # create a symlink in share pointing to the latest HPX installation
+- install(CODE
+- "set(sharedir \"${CMAKE_INSTALL_PREFIX}/share/\")
+- execute_process(
+- COMMAND \"\${CMAKE_COMMAND}\" -E create_symlink
+- \"hpx-${HPX_VERSION}\" \"hpx\"
+- WORKING_DIRECTORY \"\${sharedir}\")")
++ execute_process(COMMAND "${CMAKE_COMMAND}" -E create_symlink "hpx-${HPX_VERSION}" "hpx" WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/python")
++ install(DIRECTORY "${CMAKE_BINARY_DIR}/python/hpx" DESTINATION "share")
+
+ install( # Install external dependencies
+ DIRECTORY external/cache/boost
+--
+1.8.5.5
+
diff --git a/sys-cluster/hpx/files/hpx-0.9.8-multilib.patch b/sys-cluster/hpx/files/hpx-0.9.8-multilib.patch
new file mode 100644
index 000000000000..470e76e3b800
--- /dev/null
+++ b/sys-cluster/hpx/files/hpx-0.9.8-multilib.patch
@@ -0,0 +1,163 @@
+From 383acb45e75406fb94bb4fa86c162a78c05ab840 Mon Sep 17 00:00:00 2001
+From: Christoph Junghans <junghans@lanl.gov>
+Date: Tue, 20 May 2014 11:03:16 -0600
+Subject: [PATCH] added LIB cmake option to configure lib directory
+
+for multiarch distributions the lib directory needs to changed
+from 'lib' to 'lib64'/'lib32'. Add an cmake option to do this.
+---
+ CMakeLists.txt | 11 +++++++----
+ cmake/HPX_AddComponent.cmake | 2 +-
+ cmake/HPX_AddLibrary.cmake | 2 +-
+ plugins/binary_filter/bzip2/CMakeLists.txt | 2 +-
+ plugins/binary_filter/snappy/CMakeLists.txt | 2 +-
+ plugins/binary_filter/zlib/CMakeLists.txt | 2 +-
+ plugins/parcel/coalescing/CMakeLists.txt | 2 +-
+ src/CMakeLists.txt | 6 +++---
+ 8 files changed, 16 insertions(+), 13 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8d5df19..8ad79cb 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -192,6 +192,9 @@ else()
+ "64" ADVANCED)
+ endif()
+
++if (NOT DEFINED LIB)
++ set(LIB "lib")
++endif(NOT DEFINED LIB)
+ ###############################################################################
+ if(UNIX)
+ hpx_link_directories("${CMAKE_BINARY_DIR}/lib/hpx")
+@@ -2027,14 +2030,14 @@
+ if(NOT HPX_NO_INSTALL)
+ if(NOT ("${CMAKE_BUILD_TYPE}" STREQUAL "Debug"))
+ install(FILES ${output_dir}/lib/pkgconfig/hpx_application.pc
+- DESTINATION lib/pkgconfig)
++ DESTINATION ${LIB}/pkgconfig)
+ install(FILES ${output_dir}/lib/pkgconfig/hpx_component.pc
+- DESTINATION lib/pkgconfig)
++ DESTINATION ${LIB}/pkgconfig)
+ else()
+ install(FILES ${output_dir}/lib/pkgconfig/hpx_application_debug.pc
+- DESTINATION lib/pkgconfig)
++ DESTINATION ${LIB}/pkgconfig)
+ install(FILES ${output_dir}/lib/pkgconfig/hpx_component_debug.pc
+- DESTINATION lib/pkgconfig)
++ DESTINATION ${LIB}/pkgconfig)
+ endif()
+ endif()
+
+diff --git a/cmake/HPX_AddComponent.cmake b/cmake/HPX_AddComponent.cmake
+index afbee24..babca54 100644
+--- a/cmake/HPX_AddComponent.cmake
++++ b/cmake/HPX_AddComponent.cmake
+@@ -258,7 +258,7 @@ macro(add_hpx_component name)
+ if(${name}_INSTALL_SUFFIX)
+ hpx_library_install("${name}_component" "${${name}_INSTALL_SUFFIX}")
+ else()
+- hpx_library_install(${name}_component lib/hpx)
++ hpx_library_install(${name}_component ${LIB}/hpx)
+ endif()
+
+ foreach(target ${${name}_INI})
+diff --git a/cmake/HPX_AddLibrary.cmake b/cmake/HPX_AddLibrary.cmake
+index 7f39700..8524a45 100644
+--- a/cmake/HPX_AddLibrary.cmake
++++ b/cmake/HPX_AddLibrary.cmake
+@@ -248,7 +248,7 @@ macro(add_hpx_library name)
+ if(${name}_INSTALL_SUFFIX)
+ hpx_library_install("${name}_lib" "${${name}_INSTALL_SUFFIX}")
+ else()
+- hpx_library_install(${name}_lib lib/hpx)
++ hpx_library_install(${name}_lib ${LIB}/hpx)
+ endif()
+ endif()
+ endmacro()
+diff --git a/plugins/binary_filter/bzip2/CMakeLists.txt b/plugins/binary_filter/bzip2/CMakeLists.txt
+index 2580164..b2fbf40 100644
+--- a/plugins/binary_filter/bzip2/CMakeLists.txt
++++ b/plugins/binary_filter/bzip2/CMakeLists.txt
+@@ -38,7 +38,7 @@ macro(add_bzip2_module)
+ add_hpx_pseudo_dependencies(plugins.compression.bzip2 compress_bzip2_lib)
+
+ if(NOT HPX_NO_INSTALL)
+- hpx_library_install(compress_bzip2_lib lib/hpx)
++ hpx_library_install(compress_bzip2_lib ${LIB}/hpx)
+ endif()
+ endif()
+ endmacro()
+diff --git a/plugins/binary_filter/snappy/CMakeLists.txt b/plugins/binary_filter/snappy/CMakeLists.txt
+index 6a7bbac..47e5966 100644
+--- a/plugins/binary_filter/snappy/CMakeLists.txt
++++ b/plugins/binary_filter/snappy/CMakeLists.txt
+@@ -30,7 +30,7 @@ macro(add_snappy_module)
+ add_hpx_pseudo_dependencies(plugins.compression.snappy compress_snappy_lib)
+
+ if(NOT HPX_NO_INSTALL)
+- hpx_library_install(compress_snappy_lib lib/hpx)
++ hpx_library_install(compress_snappy_lib ${LIB}/hpx)
+ endif()
+ endif()
+ endmacro()
+diff --git a/plugins/binary_filter/zlib/CMakeLists.txt b/plugins/binary_filter/zlib/CMakeLists.txt
+index 4a188ca..e4485f7 100644
+--- a/plugins/binary_filter/zlib/CMakeLists.txt
++++ b/plugins/binary_filter/zlib/CMakeLists.txt
+@@ -38,7 +38,7 @@ macro(add_zlib_module)
+ add_hpx_pseudo_dependencies(plugins.compression.zlib compress_zlib_lib)
+
+ if(NOT HPX_NO_INSTALL)
+- hpx_library_install(compress_zlib_lib lib/hpx)
++ hpx_library_install(compress_zlib_lib ${LIB}/hpx)
+ endif()
+ endif()
+ endmacro()
+diff --git a/plugins/parcel/coalescing/CMakeLists.txt b/plugins/parcel/coalescing/CMakeLists.txt
+index 093e427..889c10c 100644
+--- a/plugins/parcel/coalescing/CMakeLists.txt
++++ b/plugins/parcel/coalescing/CMakeLists.txt
+@@ -22,7 +22,7 @@ macro(add_coalescing_module)
+ add_hpx_pseudo_dependencies(plugins.parcel.coalescing parcel_coalescing_lib)
+
+ if(NOT HPX_NO_INSTALL)
+- hpx_library_install(parcel_coalescing_lib lib/hpx)
++ hpx_library_install(parcel_coalescing_lib ${LIB}/hpx)
+ endif()
+ endmacro()
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 4f4c79c..6190839 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -312,7 +312,7 @@ set_property(TARGET hpx_serialization APPEND
+ "HPX_COROUTINE_EXPORTS")
+
+ if(NOT HPX_NO_INSTALL)
+- hpx_library_install(hpx_serialization lib/hpx)
++ hpx_library_install(hpx_serialization ${LIB}/hpx)
+ endif()
+
+ ################################################################################
+@@ -403,7 +403,7 @@ set_property(TARGET hpx APPEND
+ "HPX_COROUTINE_EXPORTS") # Do we still need this?
+
+ if(NOT HPX_NO_INSTALL)
+- hpx_library_install(hpx lib/hpx)
++ hpx_library_install(hpx ${LIB}/hpx)
+ endif()
+
+ ################################################################################
+@@ -436,7 +436,7 @@ endif()
+ set_property(TARGET hpx_init PROPERTY FOLDER "Core")
+
+ if(NOT HPX_NO_INSTALL)
+- hpx_archive_install(hpx_init lib/hpx)
++ hpx_archive_install(hpx_init ${LIB}/hpx)
+ endif()
+
+ set(HPX_CONFIG_DEFINITIONS ${HPX_CONFIG_DEFINITIONS} PARENT_SCOPE)
+--
+1.8.5.5
+